Questions sur l'installation et la configuration de Manjaro Linux.
Répondre

Blocage au boot

#1Messageil y a 4 ans

Bonjour

J'ai installé manjaro gnome-cinnamon depuis l'iso 0.8.2. Au reboot c'est OK.

Dans la foulée j'ai fait toutes les mises à jour.

Au boot, j'ai une ligne d'erreur :
[Failed] Failed to start Load Kernel Modules.
See 'systemctl status systemd-modules-load.services' for details.

Qu'est-ce que je dois faire ?

Blocage au boot

#2Messageil y a 4 ans

Vérifier ton Grub, ton fstab, etc... ?

Notamment les UUIDs, et l'ancienne histoire de GRUB_CMDLINE_DEFAULTS. En prenant une 0.8.2 et pas 0.8.3, tu as dû retomber dans le problème, surtout si tu as rajouté un noyau au passage.

Blocage au boot

#3Messageil y a 4 ans

Pour les uuid, pas de problèmes pour vérifier et modifier s'il y a lieu.

Pour l'histoire de GRUB_CMDLINE_DEFAULTS, c'est une autre paire de manches pour moi.

Comme je ne peux pas booter dessus je dois faire ça depuis Mint. Peux-tu détailler la procédure stp ?

Modifier la ligne, pas de souci, mais là où je bloque c'est pour le update-grub

Blocage au boot

#4Messageil y a 4 ans

Bon, déjà, qui est le propriétaire du Grub ?

Si tu fais un grub-install sous Mint, c'est lui qui en deviendra propriétaire, et c'est son grub.cfg qui sera utilisé. Ça devait déjà te permettre de prendre la main sous Manjaro pour faire tes modifs (et le grub-mkconfig)

Si c'est plus sérieux, tu peux passer en chroot. Ecris-toi une fois pour toutes un petit script du genre :

Mont=/mnt
Root=/dev/sdaX
Home=/dev/sdaY

mount $Root $Mont
mount $Home $Mont/home

mount -B /proc $Mont/proc
mount -B /sys $Mont/sys
mount -B /dev $Mont/dev

chroot /mnt

umount $Mont/sys && echo "/sys démontée."
umount $Mont/dev && echo "/dev démontée."
umount $Mont/proc && echo "/proc démontée."

[ $Home ] && umount $Home
umount -l $Root

exit 0


En remplaçant X et Y par tes valeurs. Ce script va te faire passer dans l'environnement de la machine visée. Tu pourras faire tes modifs, puis taper exit (ou Ctrl-D) pour revenir à ta machine de départ, en démontant proprement tes partitions.

Blocage au boot

#5Messageil y a 4 ans

Apparemment ce n'est pas la ligne GRUB_CMDLINE_DEFAULTS, pas plus que les uuid.

J'ai contrôlé les uuic = OK ; pour la ligne ..., j'ai fait, depuis mint :

modification de la ligne et enregistré

# mount /dev/sdb6 /mnt

# mount -t proc proc /mnt/proc

# mount -t sysfs sys /mnt/sys

# mount -o bind /dev /mnt/dev

# mount -t devpts pts /mnt/dev/pts/

# chroot /mnt

# grub-mkconfig -o /boot/grub/grub.cfg

# exit

au reboot c'est idem

Blocage au boot

#6Messageil y a 4 ans

Il vaut mieux l'option -B pour les montages multiples, elle est faite pour ça, mais ce n'est pas le problème.

Avais-tu reformaté ta partition système avant de réinstaller ? Ça sent un peu l'ancien fichier de configuration système qui serait resté.

Blocage au boot

#7Messageil y a 4 ans

Esclapion a écrit :Il vaut mieux l'option -B pour les montages multiples, elle est faite pour ça, mais ce n'est pas le problème.
Avais-tu reformaté ta partition système avant de réinstaller ? Ça sent un peu l'ancien fichier de configuration système qui serait resté.

Les lignes de commandes que j'ai mises sont issues du forum des rosbifs :
https://classicforum.manjaro.org/index.php?topic=241.0

L'installation a été faite sur une partition formatée, donc pas d'anciens fichiers de config.
C'est suite à la mise à jour que ça a foiré.

J'ai viré ça, je ne vais pas cherché pendant des jours ; si ça refait la même chose alors oui il faudra approfondir.
Je réinstallerai demain ; je vais en profiter pour revoir' l'agencement de mes DD.

En attendant, un grand merci à toi.

Blocage au boot

#8Messageil y a 4 ans

Les lignes de commandes que j'ai mises sont issues du forum des rosbifs :


Oui, ça traîne encore un peu partout, mais ça date.

Je ne me vois pas par contre en train de le leur signaler. :rigole:

Répondre