Questions sur l'installation et la configuration de Manjaro Linux.
Répondre

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#1Messageil y a 5 mois

Bonjour à tous,

Ici viewtopic.php?p=114311#p114311 à propos d'un
avertissement sur les permissions d'un répertoire à l'occasion d'une mise à jour,
Erwan a écrit :Il faut appliquer les droits des nouveaux paquets. Ce qui donne ceci, dans ton cas :
sudo chmod 700 /var/lib/samba/private/

Tu peux vérifier ensuite que ton dossier n'est plus listé dans le retour de cette commande :
sudo pacman -Qkk 2>&1| grep "permissions"
J'ai utilisé cette dernière commande et vu qu'il y avait plusieurs avertissements de ce type
auxquels je n'avais pas donné suite.
Problème : je ne dispose plus des nouveaux paquets dans leur état d'origine
pour appliquer les droits corrects.
Et je n'ai pas retrouvé dans mes traces de mises à jour les messages qui m'auraient aidé.
Je suis allé faire un tour du côté de... /var/cache/pacman/pkg/ mais... :saispas:
Comment faire ?
Modifié en dernier par coolinux le 06 Jui 2018, 10:38, modifié 1 fois.

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#2Messageil y a 5 mois

bonjour,

justement avec pacman -Qkk tu vas faire un check de tous tes paquets installés.
Donc si il y a une remarque au niveau d'un droit tu vas le retrouver

pacman te dit ce qu'il faut faire, appliquer les droits avec un chmod qui correspondent au paquet installé
A toi de transformer tous tes messages d'avertissement en chmod XXX /repertoire

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#3Messageil y a 5 mois

Bonsoir Papajoke,
Oui, mais ce que je ne sais pas, c'est quels sont les "bons" droits à appliquer.

Je ne suis pas sur mon système habituel, mais voici quand même un exemple de ce que je vois sur celui-ci :

┌──[coolinux / Manjaro 17.1.10 (Hakoila) gnome x86_64 - 4.14.48-2-MANJARO / sdb3 de pcb2]
├── ~
└─> sudo pacman -Qkk 2>&1| grep "permissions"
[sudo] Mot de passe de coolinux : 
coreutils : 429 fichiers au toavertissement : cups : /etc/cups/classes.conf (Les permissions ne correspondent pas)
avertissement : cups : /etc/cups/printers.conf (Les permissions ne correspondent pas)
avertissement : cups : /etc/cups/subscriptions.conf (Les permissions ne correspondent pas)
grilo-avertissement : grub : /boot/grub/grub.cfg (Les permissions ne correspondent pas)

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#4Messageil y a 5 mois

le plus simple est de lire les logs (attention aux dates)

grep permissions /var/log/pacman.log -A1
-----

sinon on peut lire dans la bd de pacman mais plus pour barbus

zcat /var/lib/pacman/local/grub*/mtree | grep "boot/grub.*mode"
./boot/grub time=1529878932.0 mode=755 type=dir

 zcat /var/lib/pacman/local/cups*/mtree | grep "etc/cups.*mode"
./etc/cups time=1524251075.22901341 mode=755 gid=209 type=dir

zcat /var/lib/pacman/local/cups*/mtree | grep "etc/cups/printer.*mode"
./etc/cups/printers.conf time=1529383263.0 mode=644
-----

sinon réinstaller les quelques paquets et bien lire le message

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#5Messageil y a 5 mois

...

┌──[coolinux / Manjaro 17.1.10 (Hakoila) gnome x86_64 - 4.14.48-2-MANJARO / sdb3 de pcb2]
├── ~
└─> grep permissions /var/log/pacman.log -A1
┌──[coolinux / Manjaro 17.1.10 (Hakoila) gnome x86_64 - 4.14.48-2-MANJARO / sdb3 de pcb2]
Nada !
On est déjà demain :lol: et la nuit portant conseil...

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#6Messageil y a 5 mois

Je suis repassé sur "mon" système (Xfce), et là j'ai bien ce qui est attendu :

┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> grep permissions /var/log/pacman.log -A1
[2017-02-19 19:24] [ALPM] warning: directory permissions differ on /etc/NetworkManager/system-connections/
filesystem: 755  package: 700
--
[2017-02-25 18:05] [ALPM] warning: directory permissions differ on /etc/NetworkManager/system-connections/
filesystem: 755  package: 700
--
[2017-02-25 18:05] [ALPM] warning: directory permissions differ on /usr/share/doc/nfs-utils/
filesystem: 644  package: 755
--
[2017-04-04 18:39] [ALPM] warning: directory permissions differ on /usr/share/doc/nfs-utils/
filesystem: 644  package: 755
--
[2017-05-14 19:21] [ALPM] warning: directory permissions differ on /etc/NetworkManager/system-connections/
filesystem: 755  package: 700
--
[2017-07-08 19:29] [ALPM] warning: directory permissions differ on /usr/share/doc/nfs-utils/
filesystem: 644  package: 755
--
[2017-07-16 18:49] [ALPM] warning: directory permissions differ on /etc/NetworkManager/system-connections/
filesystem: 755  package: 700
--
[2017-12-29 16:35] [ALPM] warning: directory permissions differ on /usr/share/doc/nfs-utils/
filesystem: 644  package: 755
--
[2018-06-17 10:36] [ALPM] warning: directory permissions differ on /var/lib/mlocate/
filesystem: 750  package: 755
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
Merci Papajoke. :clap

Après petite mésienne de trois heures sur chaque oreille, j'étudierai les commandes
"spéciales barbus". Enfin... c'est zcat que je n'ai jamais pratiqué. Le reste coule de source.
Modifié en dernier par coolinux le 04 Jui 2018, 23:19, modifié 1 fois.

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#7Messageil y a 5 mois

A oui, si tu ne consultais pas les logs de la bonne machine :gsourire:
zcat est simple c'est juste un cat dans un fichier gz (fichier mtree est compressé)

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#8Messageil y a 5 mois

... c'est sur toutes mes machines que je dois avoir des permissions inadéquates.
Ça va me faire un petit entraînement (et peut-être à d'autres imberbes qui passeront par là). :lol:

Bonne nuit, et à plus...

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#9Messageil y a 5 mois

bon aller, la bonne commande (plus propre) pour retrouver tous les répertoires d'un paquet :

zcat /var/lib/pacman/local/networkmanager-*/mtree |awk '/mode.*dir$/ {print $3"\t"$1}'|sort|uniq
on change juste networkmanager par le nom du paquet

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#10Messageil y a 5 mois

:bjr:
Mise en application des conseils reçus : réussite partielle seulement...

Rappel des fichiers incriminés :

┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> sudo pacman -Qkk 2>&1| grep "permissions"
clucene : 400 ficavertissement : cups : /etc/cups/classes.conf (Les permissions ne correspondent pas)
avertissement : cups : /etc/cups/printers.conf (Les permissions ne correspondent pas)
avertissement : cups : /etc/cups/subscriptions.conf (Les permissions ne correspondent pas)
gd : 39 fichiers au total, 0 fichier moavertissement : grub : /boot/grub/grub.cfg (Les permissions ne correspondent pas)
libvisual : 63 fichiers auavertissement : lightdm-gtk-greeter : /etc/lightdm/lightdm-gtk-greeter.conf (Les permissions ne correspondent pas)
En résumé, les permissions sont incorrectes pour :
cups : /etc/cups/classes.conf
/etc/cups/printers.conf
/etc/cups/subscriptions.conf
grub : /boot/grub/grub.cfg
lightdm-gtk-greeter : /etc/lightdm/lightdm-gtk-greeter.conf

*** Fichiers du paquet cups dans /etc/cups.
Procédure utilisée :

┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> zcat /var/lib/pacman/local/cups*/mtree |awk '/mode.*/ {print $3" : "$1}'|sort|uniq | grep '/etc/cups'
mode=644 : ./etc/cups/classes.conf
mode=644 : ./etc/cups/printers.conf
mode=644 : ./etc/cups/subscriptions.conf
mode=700 : ./etc/cups/ssl
mode=755 : ./etc/cups
mode=755 : ./etc/cups/ppd

└─> ll /etc/cups/classes.conf
-rw------- 1 root cups 128 2018-02-07 07:21 /etc/cups/classes.conf

└─> sudo chmod 644 /etc/cups/classes.conf

└─> ll /etc/cups/classes.conf
-rw-r--r-- 1 root cups 128 2018-02-07 07:21 /etc/cups/classes.conf

└─> sudo chmod -v 644 /etc/cups/printers.conf
le mode de '/etc/cups/printers.conf' a été modifié de 0600 (rw-------) en 0644 (rw-r--r--)

└─> ll /etc/cups/*.conf
-rw-r--r-- 1 root cups   128 2018-02-07 07:21 /etc/cups/classes.conf
-rw-r--r-- 1 root cups 26954 2018-04-20 19:04 /etc/cups/cups-browsed.conf
-rw-r----- 1 root cups  4655 2018-02-07 08:35 /etc/cups/cupsd.conf
-rw-r----- 1 root cups  2943 2018-06-19 04:41 /etc/cups/cups-files.conf
-rw-r--r-- 1 root lp   10797 2018-02-06 23:30 /etc/cups/cups-pdf.conf
-rw-r--r-- 1 root cups  1028 2018-05-11 15:05 /etc/cups/printers.conf
-rw-r----- 1 root cups   142 2018-06-19 04:41 /etc/cups/snmp.conf
-rw-r--r-- 1 root cups   111 2018-06-24 18:20 /etc/cups/subscriptions.conf
*** Fichier /boot/grub/grub.cfg du paquet grub

└─> zcat /var/lib/pacman/local/grub*/mtree | grep -B 1 -A 1 '\.cfg'
./boot/grub time=1527874005.0 mode=755 type=dir
./boot/grub/grub.cfg time=1527874005.0 size=37 md5digest=8a3ed34fd6d41926ff29d30852d3188b sha256digest=7fc95d49c0febe98a76e56b606a280565cb736580adecf163bc6b5aca8e7cbd8
/set mode=755

└─> sudo chmod -v 755 /boot/grub/grub.cfg
le mode de '/boot/grub/grub.cfg' a été modifié de 0400 (r--------) en 0755 (rwxr-xr-x)
*** Fichier /etc/lightdm/lightdm-gtk-greeter.conf du paquet lightdm-gtk-greeter

└─> ll /var/lib/pacman/local/lightdm-gtk-greeter*/mtree
-rw-r--r-- 1 root root 8779 2018-03-26 20:20 /var/lib/pacman/local/lightdm-gtk-greeter-1:2.0.5-1/mtree
-rw-r--r-- 1 root root 7063 2017-12-06 10:01 /var/lib/pacman/local/lightdm-gtk-greeter-settings-1.2.2-2/mtree


└─> zcat /var/lib/pacman/local/lightdm-gtk-greeter-1:2.0.5-1/mtree | grep -B 1 -A 1 'conf'
./etc/lightdm time=1522095605.331955290 mode=755 type=dir
./etc/lightdm/lightdm-gtk-greeter.conf time=1522095605.331955290 size=2970 md5digest=f697ccc6959a7a5b0e8f310b3917a8f8 sha256digest=15c3ff99e100b78ae25352d575216d205f10a459da77b72b46962e961580a82c
/set mode=755

└─> zcat /var/lib/pacman/local/lightdm-gtk-greeter-settings-1.2.2-2/mtree | grep -B 1 -A 1 'conf'
./usr/lib/python3.6/site-packages/lightdm_gtk_greeter_settings/helpers.py time=1505818577.0 size=11661 md5digest=ef3520a36dee8461c7c7d7c073f95db2 sha256digest=643ba3b5129c7dd60c648333de78a3e2f2d19b2b8f6a9d09eab251c38d0c4b6a
./usr/lib/python3.6/site-packages/lightdm_gtk_greeter_settings/installation_config.py time=1512554495.584914614 size=211 md5digest=6d69de8ea78db6c35759aba3e3e9095e sha256digest=25a30c72435ff20c8e2105e37960e4d7f532d1214b942f1ac523e0b01539b82f
./usr/lib/python3.6/site-packages/lightdm_gtk_greeter_settings/__pycache__ time=1512554495.548247911 mode=755 type=dir

└─> sudo chmod -v 755 /etc/lightdm/lightdm-gtk-greeter.conf
[sudo] Mot de passe de alain : 
le mode de '/etc/lightdm/lightdm-gtk-greeter.conf' a été modifié de 0444 (r--r--r--) en 0755 (rwxr-xr-x)
*** Résultat

jeudi 5 juillet 2018, 18:36
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> sudo pacman -Qkk 2>&1| grep "permissions"
gd : 39 fichiers au total, 0 fichier modiavertissement : grub : /boot/grub/grub.cfg (Les permissions ne correspondent pas)
libvisual : 63 fichiers au tavertissement : lightdm-gtk-greeter : /etc/lightdm/lightdm-gtk-greeter.conf (Les permissions ne correspondent pas)
C'est bon pour les fichiers cups, pas pour les autres   :?    :tetu!

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#11Messageil y a 5 mois

ce que je t'ai donné ce n'est que pour les répertoires !
Pour les fichiers :
Tu as une ligne avec

/set [****] mode=700
.... fichier x
... fichier y
/set mode=644
.... fichier z
... fichier a
donc pour un fichier en particulier, ajouter un pipe less et touver le fichier(dur dur) puis remonter à une ligne qui débute par /set
Toi, tu lisais ici la ligne suivante avec le set ... et non la commande "set" précédente !

zcat /var/lib/pacman/local/grub*/mtree | less
---

sinon réinstaller le paquet, il va te donner l'erreur
sinon demander aux autres (qui n'ont pas le même avertissement !!!) du forum de faire un ls -l de tes fichiers
/boot/grub/grub.cfg, j'ai 644


--------------------
--------------------
Me suis amusé à faire un petit script qui à l'air de bien boiter avec ces 3 petits tests :
./test.sh grub /boot/grub/grub.cfg
./test.sh networkmanager /usr/bin/nmtui-edit
./test.sh networkmanager /usr/share/dbus-1/interfaces/org.freedesktop.NetworkManager.AgentManager.xml

#!/usr/bin/env bash
pkg=( $(pacman -Q "$1") )
pkg="$1-${pkg[1]}"
echo "rep: $pkg"; 
fichier="$2"
while IFS=$'\n' read -r line; do
    #echo "$line"
    [[ "$line" =~ set.*mode= ]] && mode="$line"
    [[ "$line" =~ "$fichier"  ]] && { 
        echo "$mode";
        echo "$line"  | cut -d' ' -f1;
        exit;
     }
done < <(zcat /var/lib/pacman/local/${pkg}/mtree ) 

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#12Messageil y a 5 mois

Bonsoir tout le monde, et merci Papajoke pour ton suivi.
Toi, tu lisais ici la ligne suivante avec le set ... et non la commande "set" précédente !
Ce qui explique peut-être pourquoi, après avoir fait des modifs de permissions sur des fichiers, acceptées ou pas dans un premier temps, après redémarrage les permissions avaient encore changé (... sans ma permission :gsourire: ).

− Après modifs des permissions et juste avant d'éteindre la machine :

jeudi 5 juillet 2018, 18:36
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> sudo pacman -Qkk 2>&1| grep "permissions"
gd : 39 fichiers au total, 0 fichier modiavertissement : grub : /boot/grub/grub.cfg (Les permissions ne correspondent pas)
libvisual : 63 fichiers au tavertissement : lightdm-gtk-greeter : /etc/lightdm/lightdm-gtk-greeter.conf (Les permissions ne correspondent pas)
C'était bon pour les fichiers cups.

− Après redémarrage, sans rien modifier :

jeudi 5 juillet 2018, 23:00
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> sudo pacman -Qkk 2>&1| grep "permissions"
[sudo] Mot de passe de alain : 
clucene : 400 ficavertissement : cups : /etc/cups/classes.conf (Les permissions ne correspondent pas)
avertissement : cups : /etc/cups/printers.conf (Les permissions ne correspondent pas)
gd : 39 fichiers au total, 0 fichier moavertissement : grub : /boot/grub/grub.cfg (Les permissions ne correspondent pas)
libvisual : 63 fichiers auavertissement : lightdm-gtk-greeter : /etc/lightdm/lightdm-gtk-greeter.conf (Les permissions ne correspondent pas)
/etc/cups/classes.conf et /etc/cups/printers.conf sont à nouveau listés fautifs.

Je vais étudier ta procédure de lecture spécifique aux permissions des fichiers
et voir ce que cela donne ici.
:salut:

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#13Messageil y a 5 mois

pour les 2 fichiers cups j'ai 644 (ok) mais 4 erreurs de Groupe avec -Qkk sur des répertoires ?

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#14Messageil y a 5 mois

:bjr:
papajoke a écrit :pour les 2 fichiers cups j'ai 644 (ok)
Voici dans le détail ce que je fais sur mes deux fichiers cups fautifs,
le tout dans la même foulée, sans redémarrage :

┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> acdate
vendredi 6 juillet 2018, 11:01
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> sudo pacman -Qkk 2>&1| grep "permissions"
[sudo] Mot de passe de alain : 
clucene : 400 ficavertissement : cups : /etc/cups/classes.conf (Les permissions ne correspondent pas)
avertissement : cups : /etc/cups/printers.conf (Les permissions ne correspondent pas)
gd : 39 fichiers au total, 0 fichier moavertissement : grub : /boot/grub/grub.cfg (Les permissions ne correspondent pas)
libvisual : 63 fichiers auavertissement : lightdm-gtk-greeter : /etc/lightdm/lightdm-gtk-greeter.conf (Les permissions ne correspondent pas)
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> chmod u+x mesSH/permissions_fichiers_papajoke.sh 
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> permissions_fichiers_papajoke.sh cups /etc/cups/classes.conf
rep: cups-2.2.8-3
/set gid=209 mode=640
./etc/cups/classes.conf
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> permissions_fichiers_papajoke.sh cups /etc/cups/printers.conf
rep: cups-2.2.8-3
/set gid=209 mode=640
./etc/cups/printers.conf
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> ll /etc/cups/classes.conf /etc/cups/printers.conf
-rw------- 1 root cups  128 2018-02-07 07:21 /etc/cups/classes.conf
-rw------- 1 root cups 1028 2018-05-11 15:05 /etc/cups/printers.conf
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> acdate
vendredi 6 juillet 2018, 11:06
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> sudo chmod -v 640 /etc/cups/classes.conf /etc/cups/printers.conf
[sudo] Mot de passe de alain : 
le mode de '/etc/cups/classes.conf' a été modifié de 0600 (rw-------) en 0640 (rw-r-----)
le mode de '/etc/cups/printers.conf' a été modifié de 0600 (rw-------) en 0640 (rw-r-----)
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> ll /etc/cups/classes.conf /etc/cups/printers.conf
-rw-r----- 1 root cups  128 2018-02-07 07:21 /etc/cups/classes.conf
-rw-r----- 1 root cups 1028 2018-05-11 15:05 /etc/cups/printers.conf
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> sudo pacman -Qkk 2>&1| grep "permissions"
clucene : 400 ficavertissement : cups : /etc/cups/classes.conf (Les permissions ne correspondent pas)
avertissement : cups : /etc/cups/printers.conf (Les permissions ne correspondent pas)
gd : 39 fichiers au total, 0 fichier moavertissement : grub : /boot/grub/grub.cfg (Les permissions ne correspondent pas)
libvisual : 63 fichiers auavertissement : lightdm-gtk-greeter : /etc/lightdm/lightdm-gtk-greeter.conf (Les permissions ne correspondent pas)
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> 
Echec... et mat !
Mes changements de permissions sont pris en compte (pour l'instant)
mais l'erreur de correspondance est toujours là.

Ajout dernière minute : 640 parce que ton programme me retourne 640.

Je vais mettre comme toi 644 (mais pourquoi ?), vérifier, puis redémarrer, puis revérifier...

┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> sudo chmod -v 644 /etc/cups/classes.conf /etc/cups/printers.conf
[sudo] Mot de passe de alain : 
le mode de '/etc/cups/classes.conf' a été modifié de 0640 (rw-r-----) en 0644 (rw-r--r--)
le mode de '/etc/cups/printers.conf' a été modifié de 0640 (rw-r-----) en 0644 (rw-r--r--)
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> sudo pacman -Qkk 2>&1| grep "permissions"
gd : 39 fichiers au total, 0 fichier modiavertissement : grub : /boot/grub/grub.cfg (Les permissions ne correspondent pas)
libvisual : 63 fichiers au tavertissement : lightdm-gtk-greeter : /etc/lightdm/lightdm-gtk-greeter.conf (Les permissions ne correspondent pas)
Redémarrage [...] A suivre...
Après avoir redémarré :

┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> acdate
vendredi 6 juillet 2018, 11:28
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> ll /etc/cups/classes.conf /etc/cups/printers.conf
-rw------- 1 root cups  128 2018-02-07 07:21 /etc/cups/classes.conf
-rw------- 1 root cups 1028 2018-05-11 15:05 /etc/cups/printers.conf
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> sudo pacman -Qkk 2>&1| grep "permissions"
clucene : 400 ficavertissement : cups : /etc/cups/classes.conf (Les permissions ne correspondent pas)
avertissement : cups : /etc/cups/printers.conf (Les permissions ne correspondent pas)
gd : 39 fichiers au total, 0 fichier moavertissement : grub : /boot/grub/grub.cfg (Les permissions ne correspondent pas)
libvisual : 63 fichiers auavertissement : lightdm-gtk-greeter : /etc/lightdm/lightdm-gtk-greeter.conf (Les permissions ne correspondent pas)
┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
Les permissions ont été modifiées "à l'insu de mon plein gré"
et par conséquent je retrouve les avertissements correspondants. :roll:

Complément d'info :

┌──[alain / Manjaro 17.1.11 (Hakoila) xfce x86_64 - 4.14.52-1-MANJARO / sdb6 de pcb2]
├── ~
└─> ls -ld /etc/cups/
drwxr-xr-x 4 root cups 4096  4 juil. 10:43 /etc/cups/

Les permissions (fichiers et/ou répertoires) ne correspondent pas

#15Messageil y a 5 mois

:salut:

Perso les permissions de cups et de grub, je n'y touche plus. Si tu as personnalisé ton grub ou que tu utilises au quotidien une imprimante, ça va te mettre un souk d'enfer...
De plus la monté de règles de sécurité concernant une vulgaire imprimante, je vois pas trop l'intérêt, à moins d'avoir une carte mémoire insérée en permanence dans cette dernière et que cette carte contienne des données sensibles ? :rigole:

Mais chacun voit midi à sa porte. :wink:

Répondre