Questions sur l'installation et la configuration de Manjaro Linux.
Répondre

MAJ impossible à cause de dépendance poppler-qt4

#1Messageil y a 3 mois

Bonjour à tous !

Voulant faire la dernière mise à jour, j'ai le retour suivant qui bloque le processus :

la satisfaction des dépendances a échoué. 
la suppression de "poppler-qt4" casse la dépendance "poppler-qt" requise par kfilemetadatak
la suppression de "poppler-qt4" casse la dépendance "poppler-qt4" requise par python-popple
Est-ce que quelqu'un saurait comment sortir de cette situation ?

J'ai tenté de désinstaller "poppler" : impossible pour les mêmes raisons... (poppler semble être lié à la lecture des fichiers PDF)

Un grand merci à la communauté ! :sourire:
Modifié en dernier par Erwan le 24 Mai 2018, 18:04, modifié 2 fois.
Raison :Sujet résolu non coché

MAJ impossible à cause de dépendance poppler-qt4

#2Messageil y a 3 mois

bonjour,
il existe uniquement une version qt5 ! qt4 est plus que déconseillé depuis un bon moment et d'ailleur il n'existe plus de version qt4 de poppler
kfilemetadata utilise justement la version qt5

MAJ impossible à cause de dépendance poppler-qt4

#3Messageil y a 3 mois

Merci Papajoke pour cette information.
J'ai donc installé la version 5 recommandée... J'ai tenté de faire la mise à jour... Mais ça bloque toujours... J'ai tenté de désintaller "poppler" (ainsi que "poppler-qt4") : cela m'est refusé (pour les mêmes raisons de dépendance).

erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: cups-filters : supprimer poppler casse la dépendance « poppler »
:: frescobaldi : supprimer poppler casse la dépendance « poppler »
:: libreoffice-fresh : supprimer poppler casse la dépendance « poppler>=0.24.0 »
:: pdfgrep : supprimer poppler casse la dépendance « poppler »
:: poppler-glib : supprimer poppler casse la dépendance « poppler=0.61.1 »
:: poppler-qt4 : supprimer poppler casse la dépendance « poppler=0.61.1 »
:: poppler-qt5 : supprimer poppler casse la dépendance « poppler=0.61.1 »
:: texlive-bin : supprimer poppler casse la dépendance « poppler »
Que faire ?

MAJ impossible à cause de dépendance poppler-qt4

#4Messageil y a 3 mois

Bonjour, que donne le retour de :

pacman -Qi python-poppler-qt4
:?:

MAJ impossible à cause de dépendance poppler-qt4

#5Messageil y a 3 mois

Bonjour Erwan ! :wink:
Merci pour ton aide.

Voici le retour de cette commande :

Nom                      : python-poppler-qt4
Version                  : 0.24.0-1
Description              : A Python 3 binding to poppler-qt4
Architecture             : x86_64
URL                      : https://github.com/wbsoft/python-poppler-qt4
Licences                 : LGPL
Groupes                  : --
Fournit                  : --
Dépend de                : python-pyqt4  poppler-qt4
Dépendances opt.         : --
Requis par               : frescobaldi
Optionnel pour           : --
Est en conflit avec      : python-poppler-qt
Remplace                 : python-poppler-qt
Taille installée         : 320,00 KiB
Paqueteur                : Unknown Packager
Compilé le               : dim. 03 juil. 2016 10:58:05 CEST
Installé le              : dim. 03 juil. 2016 11:00:15 CEST
Motif d’installation     : Installé comme dépendance d’un autre paquet
Script d’installation    : Non
Validé par               : --

MAJ impossible à cause de dépendance poppler-qt4

#6Messageil y a 3 mois

Alors, on va désinstaller ce qui pose problème puis reconstruire le paquet Aur (frescobaldi) avec le Qt5 qui va bien ;)

sudo pacman -Rsn python-poppler-qt4 poppler-qt4 frescobaldi

MAJ impossible à cause de dépendance poppler-qt4

#7Messageil y a 3 mois

attention, poppler est la librairie (console) et tu as en plus (les "gui") poppler-qt4 ou poppler-qt5 qui l'utilise.
poppler est en tout cas obligatoire pour beaucoup d'applications.

MAJ impossible à cause de dépendance poppler-qt4

#8Messageil y a 3 mois

Oui mais ça bloque encore : voici le retour de cette commande

vérification des dépendances...
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: kfilemetadata4 : supprimer poppler-qt4 casse la dépendance « poppler-qt »
@Papajoke

Oui, tu as raison : j'avais mené des recherches en ce sens...

MAJ impossible à cause de dépendance poppler-qt4

#9Messageil y a 3 mois

un sudo pacman -Rd poppler-qt4 après tu installes la version qt5 :

sudo pacman -S poppler-qt5 --asdeps
ps:
On n'installe JAMAIS une librairie directement avec -S seul
sinon ce paquet est marqué "installé explicitement" donc il ne sera jamais un paquet orphelin.
Il pourrai donc rester 10 ans sur notre machine alors qu'il n'est utilisé par aucun programme :roll:

MAJ impossible à cause de dépendance poppler-qt4

#10Messageil y a 3 mois

@papajoke : Il semble bien que Jivaro a déjà installé qt5 112348:wink:

MAJ impossible à cause de dépendance poppler-qt4

#11Messageil y a 3 mois

@ Papajoke
Impasse encore. Voici le retour :

résolution des dépendances...
recherche des conflits entre paquets...
:: poppler et poppler-qt4 sont en conflit. Supprimer poppler-qt4 ? [o/N] o
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: kfilemetadata4 : supprimer poppler-qt4 casse la dépendance « poppler-qt »
:: poppler-glib : installer poppler (0.63.0-1) casse la dépendance « poppler=0.61.1 »
:: python-poppler-qt4 : supprimer poppler-qt4 casse la dépendance « poppler-qt4 »


MAJ impossible à cause de dépendance poppler-qt4

#12Messageil y a 3 mois

essaye alors sudo pacman -Rdd poppler-qt4

MAJ impossible à cause de dépendance poppler-qt4

#13Messageil y a 3 mois

Bonjour,
Je pense qu'il faut supprimer le paquet kfilemetadata4 et ses dépendances.

sudo pacman -Rns kfilemetadat4

MAJ impossible à cause de dépendance poppler-qt4

#14Messageil y a 3 mois

a oui, ce paquet n'existe même pas :o

MAJ impossible à cause de dépendance poppler-qt4

#15Messageil y a 3 mois

@ letransfuge (que je salue au passage et que je remercie)
J'avais essayé cela, tout seul de mon côté, sans aucun succès ! :saispas:

@Papajoke
Félicitations ! Je peux enfin mettre à jour le système ! Un chaleureux merci ! :salut:
Modifié en dernier par Jivaro le 19 Avr 2018, 16:01, modifié 1 fois.

MAJ impossible à cause de dépendance poppler-qt4

#16Messageil y a 3 mois

papajoke a écrit :
il y a 3 mois
a oui, ce paquet n'existe même pas :o
En fait il n'existe plus.
C'est lui qui bloquait le dernière maj chez moi (ou plutôt sa dépendance poppler-qt4).
J'ai donc supprimé kfilemetadata4, poppler-qt4, kdegraphics-mobipocket et libbaloo4.
Faut dire que cette install a plus de 4 ans... :pappy:

MAJ impossible à cause de dépendance poppler-qt4

#17Messageil y a 3 mois

Merci pour l'aide apportée et ces explications bien utiles ! :bien

MAJ impossible à cause de dépendance poppler-qt4

#18Messageil y a 3 mois

@Jivaro

:salut:

MAJ impossible à cause de dépendance poppler-qt4

#19Messageil y a 3 mois

:clap Si ton sujet est résolu... :merci:

Répondre