Questions sur l'installation et la configuration de Manjaro Linux.

Ouverture de session xfce en boucle

#1Messageil y a 1 semaine

Salut à tous
Merci d'avance de l'aide que chacun peut apporter, merci quand même sinon.

Suite, j'imagine, à la grosse mise à jour entreprise hier sur mon ordi hier, les démarrages successifs ont tous été chaotiques, jusqu'à arriver continuellement à l'écran d'ouverture de session qui revient en boucle après insertion du mot de passe.

Je suis sur mon téléphone.
Ceci était l'état de ma bécane avant la mise à jour.

System:    Host: stap-pc Kernel: 4.4.59-1-MANJARO x86_64 (64 bit)
           Desktop: Xfce 4.12.3 Distro: Manjaro Linux
Machine:   Device: laptop System: TOSHIBA product: Satellite A500 v: PSAR3E-01H009FR
           Mobo: TOSHIBA model: KSKAA v: 1.00
           BIOS: TOSHIBA v: V1.30 date: 09/04/2009
CPU:       Dual core Intel Core2 Duo P7450 (-MCP-) speed/max: 800/2133 MHz
Graphics:  Card: NVIDIA GT216M [GeForce GT 230M]
           Display Server: X.Org 1.19.3 driver: nvidia
           Resolution: 1366x768@60.00hz
           GLX Renderer: GeForce GT 230M/PCIe/SSE2
           GLX Version: 3.3.0 NVIDIA 340.101
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8168
           Card-2: Realtek RTL8191SEvB Wireless LAN Controller
           driver: rtl8192se
Drives:    HDD Total Size: 500.1GB (86.7% used)
Info:      Processes: 133 Uptime: 8 min Memory: 1306.1/3922.1MB
           Client: Shell (bash) inxi: 2.3.8 

Ouverture de session xfce en boucle

#2Messageil y a 1 semaine

Bonjour
As tu essayé de booter en console ?
Ça permettrait de contourner le DM.

75745

Ouverture de session xfce en boucle

#3Messageil y a 1 semaine

Coucou
J avais essayé mais il me demande mon login...
Pourtant quand je le rentre il m'indique la date de mon dernier login puis que such directory n'existe pas.
Il est possible que je me trompe mais je ne crois pas....
Puis me log in with home....
Comment puis je m'assurer du bon login?

Ouverture de session xfce en boucle

#4Messageil y a 1 semaine

On va essayer de créer un autre utilisateur pour voir si la pile graphique est bonne. Tu te connecte en root , puis:

# gpasswd -a users wheel -m toto2
# passwd toto2
su toto2
startx

Ouverture de session xfce en boucle

#5Messageil y a 1 semaine

Cette ligne de code me répond:
User users does not exist

Ouverture de session xfce en boucle

#6Messageil y a 1 semaine

Bjr,

Essaies

useradd -m -g wheel toto
passwd toto
Puis tu te connectes avec l'utilisateur toto

Ouverture de session xfce en boucle

#7Messageil y a 1 semaine

Merci, ça a fonctionné
je suis en effet en controle de mon PC sous l'utilisateur TOTO
cependant, mon utilisateur principal n'est toujours pas accessible et donc les dossiers non plus.

Je viens de tenter une mise à jour et tout est à jour, j'ai redémarré plusieurs fois et le problème persiste.
une idée de comment je peux reprendre la main sur mon compte principal?

merci à nouveau

Ouverture de session xfce en boucle

#8Messageil y a 1 semaine

En premier lieu, il faudrait que tu arrives à voir ce qu'il y a sous ton /home/
Depuis ton compte toto

 sudo cd /home/ton-compte-principal 
 sudo ls -als
 
Normalement tu dois retrouver tous tes fichiers ( les fichiers avec un . sont des fichiers ou répertoires de configuration du compte.
Si tout te semble OK, renommes les répertoires .config, .local
Efface ce qu'il y a dans le répertoire .cache

Tu te déconnectes et reconnectes sur le compte principal ( et on verra si ça marche :roll: )
Bon courage

Ouverture de session xfce en boucle

#9Messageil y a 6 jours

Merci mais donc:
Tout d'abord je comprends pas les instructions de renommer les dossiers.
Pour moi ce n'est pas clair et du coup je ne sais pas en quoi je dois renommer vers deux dossiers dont tu me parles...navré

Ensuite lorsque je rentre la commande en root j'ai ce retour là qui m'avance pas trop en fait...

Sudo : cd : commande introuvable
je coince... :saispas::lol:

Ouverture de session xfce en boucle

#10Messageil y a 6 jours

:salut:
Ok

Pour la première commande essaies sans le sudo

Ce que je te propose c'est d'aller te positionner dans l'arborescence de ton home ( celui qui a des problèmes) avec la commande cd ( change directory)

Une fois que tu es dans ce répertoire tu listes les fichiers et répertoires ( ls -als )

Les répertoires ou fichiers ( .config , .local, .xfce4, . ..) que je te proposes de renommer sont ceux qui contiennent ta configuration utilisateur.
( si un des fichiers est corrompu cela peut être une raison à ton problème).
Si tu te connectes avec ton utilisateur principal et que le système ne trouve pas les fichiers de configuration utilisateur , il va les recréer et tu vas revenir à la configuration initiale.

Ps : si tu n'es pas habitué à la ligne de commande , on va y aller tranquillement : arrêtes toi à la commande

ls -als
et postes le résultat

Bon courage

Ouverture de session xfce en boucle

#11Messageil y a 6 jours

:bjr:
patri-arch a écrit :
il y a 6 jours
:salut:
Ok

Pour la première commande essaies sans le sudo

Ce que je te propose c'est d'aller te positionner dans l'arborescence de ton home ( celui qui a des problèmes) avec la commande cd ( change directory)
Une fois que tu es dans ce répertoire tu listes les fichiers et répertoires ( ls -als )
Les répertoires ou fichiers ( .config , .local, .xfce4, . ..) que je te proposes de renommer sont ceux qui contiennent ta configuration utilisateur.
( si un des fichiers est corrompu cela peut être une raison à ton problème).
Si tu te connectes avec ton utilisateur principal et que le système ne trouve pas les fichiers de configuration utilisateur , il va les recréer et tu vas revenir à la configuration initiale.

Ps : si tu n'es pas habitué à la ligne de commande , on va y aller tranquillement : arrêtes toi à la commande

ls -als
et postes le résultat

Bon courage
Il s'agissait de taper sudo avec un s minuscule et non en majuscule S!!
Ceci explique peut-être cela ...?
La syntaxe en ligne de commande est sensible à la casse !!

Ouverture de session xfce en boucle

#12Messageil y a 6 jours

Merci de votre patience
janodherepio, tu fais bien de rappeller les basiques avec moi, même si en l'occurence j'avais bien tapé en s minuscule, la retranscription seule etait erronnée.

bon et bien lorsque je tape la commande avec mon nom d'utilisateur "stap" rien ne se passe avec ou sans le sudo.
Alors que c'est le nom d'utilisateur correct. D'ailleurs il se présente lors de l'ouverture de session. et d'ailleurs si je liste tous les utilisateurs avec cette commande

cut -d: -f1 /etc/passwd
le résultat est bien "stap" et "toto".


Ensuite si je tape la commande "ls -als" que tu me donnes Patri Arch, alors je me retrouve avec les détails du compte toto...
je les poste ce-dessous...
Il est clair que pour moi chacun de vos posts est une aide précieuse, une mine d'info et un petit casse tête aussi :gsourire:

Merci à tous

[root@stap-pc toto]# sudo cd /home/stap
sudo: cd : commande introuvable
[root@stap-pc toto]# cd /home/stap
bash: cd: /home/stap: Aucun fichier ou dossier de ce type
[root@stap-pc toto]# cd /home/stap-pc
bash: cd: /home/stap-pc: Aucun fichier ou dossier de ce type
[root@stap-pc toto]# ls -als
total 8288
   4 drwx------ 19 toto wheel    4096 13 janv. 09:59 .
   4 drwxr-xr-x  4 root root     4096 12 janv. 16:42 ..
   4 -rw-------  1 toto wheel      42 12 janv. 17:02 .bash_history
   4 -rw-r--r--  1 toto wheel      21 30 oct.  00:19 .bash_logout
   4 -rw-r--r--  1 toto wheel     118 23 févr.  2017 .bash_profile
   4 -rw-r--r--  1 toto wheel     840 23 févr.  2017 .bashrc
   4 -rw-r--r--  1 toto wheel    3977 30 oct.  00:19 .bashrc.pacnew
   4 drwxr-xr-x  2 toto wheel    4096 12 janv. 16:45 Bureau
   4 drwxr-xr-x  6 toto wheel    4096 13 janv. 10:00 .cache
   4 drwxr-xr-x 13 toto wheel    4096 12 janv. 17:07 .config
   8 -rw-r--r--  1 toto wheel    4855 30 oct.  00:49 .dir_colors
   4 -rw-r--r--  1 toto wheel      23 12 janv. 16:45 .dmrc
   4 drwxr-xr-x  2 toto wheel    4096 12 janv. 16:45 Documents
   4 -rw-------  1 toto wheel      16 12 janv. 16:45 .esd_auth
   4 drwx------  3 toto wheel    4096 12 janv. 16:45 .gnupg
   4 drwxr-xr-x  2 toto wheel    4096 11 janv. 17:58 .guayadeque
   4 -rw-------  1 toto wheel     322 13 janv. 09:59 .ICEauthority
   4 drwxr-xr-x  3 toto wheel    4096 23 avril  2016 .icons
   4 drwxr-xr-x  2 toto wheel    4096 12 janv. 16:45 Images
   4 drwxr-xr-x  3 toto wheel    4096 12 janv. 16:45 .local
   4 drwxr-xr-x  2 toto wheel    4096 12 janv. 16:45 Modèles
   4 drwx------  5 toto wheel    4096 12 janv. 16:45 .mozilla
   4 drwxr-xr-x  2 toto wheel    4096 12 janv. 16:45 Musique
   4 drwx------  3 toto wheel    4096 12 janv. 16:45 .nv
   4 -rw-r--r--  1 toto wheel     104  4 janv. 04:17 .profile
   4 drwxr-xr-x  2 toto wheel    4096 12 janv. 16:45 Public
   4 drwxr-xr-x  2 toto wheel    4096 12 janv. 16:45 Téléchargements
   4 drwxr-xr-x  3 toto wheel    4096 12 janv. 16:45 .thumbnails
   4 drwxr-xr-x  2 toto wheel    4096 12 janv. 16:45 Vidéos
   4 -rw-------  1 toto wheel      52 13 janv. 09:59 .Xauthority
   4 -rwxr-xr-x  1 toto wheel     100 30 oct.  00:49 .Xclients
   4 -rw-r--r--  1 toto wheel    1500  4 janv. 04:17 .xinitrc
8148 -rw-------  1 toto wheel 8335595 13 janv. 14:53 .xsession-errors
   8 -rw-------  1 toto wheel    6435 12 janv. 17:47 .xsession-errors.old
[root@stap-pc toto]# sudo cd /home/stap
sudo: cd : commande introuvable
[root@stap-pc toto]#  cd /home/stap
bash: cd: /home/stap: Aucun fichier ou dossier de ce type
[root@stap-pc toto]# 

Ouverture de session xfce en boucle

#13Messageil y a 6 jours

Si je résumes tu as ton utilisateur principal qui s’appelle stap
Postes le résultat de la commande suivante, pour vérifier que ton utilisateur stap a bien un répertoire utilisateur

cd /home
ls -als

Ouverture de session xfce en boucle

#14Messageil y a 6 jours

ok le voici
et en effet il n'apparait pas

[root@stap-pc home]# cd /home
[root@stap-pc home]# ls -als
total 28
 4 drwxr-xr-x  4 root root   4096 12 janv. 16:42 .
 4 drwxr-xr-x 17 root root   4096 12 janv. 14:05 ..
16 drwx------ 59 root root  16384 12 oct.   2016 lost+found
 4 drwx------ 19 toto wheel  4096 13 janv. 09:59 toto

Ouverture de session xfce en boucle

#15Messageil y a 6 jours

C'est normal que tu n'arrives pas à te connecter , ton répertoire utilisateur à disparu.
Je ne sais pas comment tu as pu en arriver là :saispas:

A l'installation, avais tu une partition home séparée ?

Passes la commande

more /etc/fstab
C'est le fichier qui décrit comment sont montées les partitions du système

Ouverture de session xfce en boucle

#16Messageil y a 6 jours

En effet j avais une partition /home séparée.
de plus je suis allé voir sur gparted, pour m'y connecter il m'a demandé de m'identifier avec une popup proposant stap
https://picyoo.com/photo/2147488888
et toto, j'y suis entré en me connectant avec stap.... donc c'est quelque part...
perso j y comprends rien.... à part la grosse mise à jour que j'ai faite après 8 mois d'inactivité.... je n'explique pas.

les partitions sont ici : https://picyoo.com/photo/2147488887

voivi le résultat de ta commande :

[root@stap-pc toto]# more /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>                           <mount point>  <type>  <options>  <dum
p>  <pass>
UUID=39b290b9-bead-4322-ac63-8a61972d6f7f /boot          ext2    defaults,noatim
e 0       2
UUID=158ba5ee-1e55-4e67-9c2d-5d533653ac62 swap           swap    defaults,noatim
e 0       0
UUID=5dcbc6f8-c2d5-4252-a049-9f026a52b3c6 /              ext4    defaults,noatim
e 0       1
UUID=934a29ce-4d3e-467d-bee2-01b28e90d947 /home          ext4    defaults,noatim
e 0       2

Ouverture de session xfce en boucle

#17Messageil y a 6 jours

Tout à l'air normal au niveau des partitions.
Ce qui me gène c'est que ton /home est presque plein ( ce doit être les fichiers de ton utilisateur principal), mais on ne voit rien avec la commande ls -als de ton /home

exceptionnellement , passes en root

su
 
tu rentres le mot de passe root (c'est peut être le même que ton utilisateur stag , çà dépend comment tu as installé)
et

cd /home
ls -als
Et aussi

find / -name stag 

Ouverture de session xfce en boucle

#18Messageil y a 6 jours

et bah.... permission non accordée qui me dit après avoir mouliné une recherche

[toto@stap-pc ~]$ su
Mot de passe : 
[root@stap-pc toto]# cd /home
[root@stap-pc home]# ls -als
total 28
 4 drwxr-xr-x  4 root root   4096 12 janv. 16:42 .
 4 drwxr-xr-x 17 root root   4096 12 janv. 14:05 ..
16 drwx------ 59 root root  16384 12 oct.   2016 lost+found
 4 drwx------ 19 toto wheel  4096 13 janv. 18:15 toto
[root@stap-pc home]# find / -name stap
/var/lib/lightdm-data/stap
/var/lib/AccountsService/users/stap
/var/lib/AccountsService/icons/stap
/var/db/sudo/lectured/stap
find: ‘/run/user/1001/gvfs’: Permission non accordée

Ouverture de session xfce en boucle

#19Messageil y a 6 jours

stagoog a écrit :
il y a 6 jours
et bah.... permission non accordée qui me dit après avoir mouliné une recherche
T’inquiète, ça fait la même chose chez moi !
Ca confirme que ton répertoire utilisateur stag a disparu, mais je serais bien curieux de savoir ce qui rempli la partition /home
un petit :

df -h 
donne quoi ?

Ouverture de session xfce en boucle

#20Messageil y a 6 jours

tu me rassures
s'il a disparu, la bonne nouvelle que tu vas m'apporter à n'en point douter c'est qu'en 2 3 manip je vais le recréer et reprendre la main sur mes fichiers.... hein... dis...?
ce que t'es chouette

[root@stap-pc toto]# df -h
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
dev                2,0G       0  2,0G   0% /dev
run                2,0G    1,2M  2,0G   1% /run
/dev/sda3           24G     13G   11G  55% /
tmpfs              2,0G     22M  1,9G   2% /dev/shm
tmpfs              2,0G       0  2,0G   0% /sys/fs/cgroup
tmpfs              2,0G     37M  1,9G   2% /tmp
/dev/sda1           99M     86M  8,2M  92% /boot
/dev/sda4          427G    387G   19G  96% /home
tmpfs              392M     20K  392M   1% /run/user/1001
[root@stap-pc toto]# 

Répondre