Questions générales sur Manjaro Linux.
S'il vous plaît, avant de poster, essayez la fonction de recherche du forum.
Répondre

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#1Messageil y a 3 mois

Bonjour,
Suite de mes aventures avec Manjaro (j'ai vraiment la loose :colère: )
J'ai désactivé la carte graphique Nvidia dans le bios :triste:
J'ai formaté ma partition sda3, et ré-installé Manjaro 17.1.8 (17.1.10 dispo...)
Je n'ai pas touché à la partition système EFI dev/sda1
J'ai fait le nécessaire sur Grub pour que Manjaro ait la main
Tout marche, sauf après un boot à froid !
Si je j'éteins le portable et le rallume, le grub est bien celui de Manjaro, mais il plante : écran noir
(Ubuntu boot bien sur le même disque SSD...)

J'ai donc essayé pas mal de lignes de commande, dont l'install et la mise à jour du grub en EFI qui passent bien, et d'autres pour vérifier les erreurs. Et il y en a un retour qui n'est pas normal :

sudo os-prober
Il n'y a que Ubuntu dans la liste (re-verifié en TTY après Grub)
Les UUID pour Manjaro correspondent dans le retour de blkid et lignes de Grub.cfg
Comment me sortir de cette impasse ?
Merci de vos conseils
Modifié en dernier par lopasilver le 24 Jui 2018, 10:54, modifié 1 fois.

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#2Messageil y a 3 mois

tu peux faire un retour de

sudo parted -l

( à partir de la clé USB par exemple )

-il reste une partition dédié pour Ubuntu ?
-y-a-t-il d'autres partitions autre que manjaro ?
-à partir de quel distro tu as ré-installé le Grub ?

cas à part : - le problème video est uniquement à froid ?

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#3Messageil y a 3 mois

Voilà :

[philippe@probook ~]$ sudo parted -l
[sudo] Mot de passe de philippe : 
Modèle: ATA Samsung SSD 850 (scsi)
Disque /dev/sda : 500GB
Taille des secteurs (logiques/physiques): 512B/512B
Table de partitions : gpt
Disk Flags: 

Numéro  Début   Fin     Taille  Système de fichiers  Nom                   Fanions
 1      1049kB  538MB   537MB   fat32                EFI System Partition  démarrage, esp
 2      538MB   84,4GB  83,9GB  ext4                 Ubuntu
 3      84,4GB  168GB   83,9GB  ext4
-il reste une partition dédié pour Ubuntu ?
Oui sda2
-y-a-t-il d'autres partitions autre que manjaro ?
Bein, Ubuntu et l'EFI sda1
-à partir de quel distro tu as ré-installé le Grub ?
Manjaro of course !
cas à part : - le problème video est uniquement à froid ?
Avec la SUPER loose que je viens d'avoir ce soir :tetu! , non ce n'est pas uniquement en bootant à froid que Manjaro plante après le grub ! En fait je suis obligé de booter en TTY (mettre 3 dans Grub options), de faire un grub-update et de rebooter tout de suite pour que l'ouverture de session se lance bien (fait deux fois de suite pour qu'il se lance la dernière fois).
Maintenant que le système est à jour, que firefox marche (en anglais...), et que j'ai enfin retrouvé mon password pour le forum : je ne l'eteint plus :fete:

Mais j'ai toujours :

[philippe@probook ~]$ sudo os-prober
/dev/sda2:Ubuntu 17.10 (17.10):Ubuntu:linux
[philippe@probook ~]$ 

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#4Messageil y a 3 mois

Bonjour.
J'ai vérifié chez moi et os-prober ne détecte que mon Arch ;

$  sudo os-prober
/dev/sdb1:Arch Linux (rolling):Arch:linux
Os-prober est loin d'être parfait et est de toutes façons un programme issu de l'installeur de Debian. De plus, je ne vois pas l'intérêt de détecter la distro active...
Que donne la commande depuis Manjaro:

sudo grub-mkconfig -o /boot/grub/grub.cfg

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#5Messageil y a 3 mois

je pense que os-prober ne remonte que les autres os systèmes.

pense à ajouter les autres noyaux ( lts 4.14 , 4.16 et 4.17 )

sudo mhwd-kernel -i linux414
sudo mhwd-kernel -i linux416
sudo mhwd-kernel -i linux417
dans manjaro settings tu dois pouvoir ajouter les langues
pense a verifier après dans les préférences de FF pour la langue par défaut affichage

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#6Messageil y a 3 mois

Bonjour à tous,
lemust83 a écrit :
il y a 3 mois
Que donne la commande depuis Manjaro:

[philippe@probook ~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
[sudo] Mot de passe de philippe : 
Création du fichier de configuration GRUB…
Arrière-plan trouvé : /usr/share/grub/background.png
Image Linux trouvée : /boot/vmlinuz-4.14-x86_64
Image mémoire initiale trouvée : /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Ubuntu 17.10 (17.10) trouvé sur /dev/sda2
Found memtest86+ image: /boot/memtest86+/memtest.bin
fait
[philippe@probook ~]$ 
Je ne savais pas que os-prober venait de Debian, et j'ai cru à une erreur de mon install
La vérité est ailleurs selon toi ?
Car j'ai plutot fait ces 2 commande là sur mon portable pour arriver à booter avec l'interface graphique :

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
sudo update-grub
Faudrait bien que je teste un reboot :saispas:
Modifié en dernier par lopasilver le 23 Jui 2018, 10:32, modifié 2 fois.

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#7Messageil y a 3 mois

stephane a écrit :
il y a 3 mois
pense à ajouter les autres noyaux ( lts 4.14 , 4.16 et 4.17 )
Bonjour Stéphane,
Suis sous 414 pour le moment. J'aimerais bien résoudre ce problème d'ouverture de session avant. Mais je le ferais ! dans quelques jours....
dans manjaro settings tu dois pouvoir ajouter les langues
pense à vérifier après dans les préférences de FF pour la langue par défaut affichage
Le problème avec Firefox en english s'est résolu en mettant à jour Manjaro (700 Mo+)

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#8Messageil y a 3 mois

Bonjour.
update-grub est en fait un alias de grub-mkconfig. Je voulais m'assurer que tu étais bien avec la version Grub2 de Manjaro. Je plussois pour avoir un autre noyau en secours.
Par contre tu arrives a booter normalement ou en passant par la console de grub?
Dans ce cas, ça voudrait dire que c'est Ubuntu qui a la main.

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#9Messageil y a 3 mois

lemust83 a écrit :
il y a 3 mois
Par contre tu arrives a booter normalement ou en passant par la console de grub?
Dans ce cas, ça voudrait dire que c'est Ubuntu qui a la main.
Merci de ton aide :merci:
Sur le Grub au démarrage, il y a un logo vert Manjaro en bas à droite :roll: C'est un boot normal à ma connaissance : cela marche bien UNIQUEMENT si j'ai fait un update-grub & reboot en TTY au boot précédant.. Du moins, c'est seule la méthode que j'ai trouvé. Il faut parfois que je le fasse deux fois, donc pas vraiment reproductible à 100%.

J'ai retiré le disque dur, et mis un SSD, mais les entrées du efiboot manager reflètent encore les partitions du disque dur. Est-ce cela qui me cause ces soucis ?
Si j'efface ces entrées inutiles, que ce passera-t-il si j'ai besoin de remettre mon disque dur (faut que je garde Windows dessus pour la période de garantie)

[philippe@probook ~]$ sudo efibootmgr
[sudo] Mot de passe de philippe : 
BootCurrent: 0013
Timeout: 0 seconds
BootOrder: 0013,0012,000C,000A,0010,000D,000B,000E,0000,0001,0002,0003,0004,0005,0006,0007,0008,0009,000F,0011
Boot0000  Startup Menu
Boot0001  System Information
Boot0002  Bios Setup
Boot0003  3rd Party Option ROM Management
Boot0004  System Diagnostics
Boot0005  System Diagnostics
Boot0006  System Diagnostics
Boot0007  System Diagnostics
Boot0008  Boot Menu
Boot0009  HP Recovery
Boot000A* IPV4 Network - Realtek PCIe GBE Family Controller
Boot000B* HGST HTS541010B7E610 
Boot000C  USB:  
Boot000D  USB:  
Boot000E* Intel Corporation: Realtek PXE B02 D00
Boot000F  Network Boot
Boot0010* IPV6 Network - Realtek PCIe GBE Family Controller
Boot0011  Gestion tierce de la ROM optionnelle
Boot0012* ubuntu
Boot0013* manjaro
Boot0016  JetFlash Mass Storage Device 172947151
[philippe@probook ~]$ 

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#10Messageil y a 3 mois

par hasard
tu as vérifié les UUID

sudo lsblk -fs
cat /etc/fstab

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#11Messageil y a 3 mois

Oui, déjà verifié, mais je re-confirme, ça match :

[philippe@probook ~]$ sudo lsblk -fs
[sudo] Mot de passe de philippe : 
NAME  FSTYPE LABEL UUID                                 MOUNTPOINT
sda1  vfat         7640-067A                            /boot/efi
└─sda                                                   
sda2  ext4         6b617664-7ae8-4af5-a667-d78a50908d5d 
└─sda                                                   
sda3  ext4         cebf9e52-b182-466d-94ed-b2f3dd120de8 /
└─sda                                                   
[philippe@probook ~]$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=7640-067A                            /boot/efi      vfat    defaults,noatime 0 2
UUID=cebf9e52-b182-466d-94ed-b2f3dd120de8 /              ext4    defaults,noatime,discard 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
[philippe@probook ~]$ 
Tiens, je m'aperçois que j'ai oublié de refaire le fichier swap... mais avec 8 Go de Ram, est-ce absolument nécéssaire

Edit : testé un reboot "à chaud" sans souci ce soir :pompom:
Modifié en dernier par lopasilver le 23 Jui 2018, 22:34, modifié 1 fois.

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#12Messageil y a 3 mois

Tiens, je m'aperçois que j'ai oublié de refaire le fichier swap... mais avec 8 Go de Ram, est-ce absolument nécéssaire
Non, sauf pour l'hibernation , mais un redémarrage classique est la plupart du temps plus rapide et moins problématique qu'une sortie de veille prolongée.
Avec "seulement" 4 go, je n'ai pas de swap.

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#13Messageil y a 3 mois

J'avoue être vraiment déçu de ne pas pouvoir utiliser mon portable neuf qui plante tout le temps...
Hier, après un reboot réussi :pompom: , j'ai donc installé le noyau linux416 et depuis il plante quoique je sélectionne comme noyau 414 ou 416, 414 fallback...
Sur cette page tout en bas, on voit que le portable marche bien sous Arch, mais il n'y a pas mention de qui a contribué...
Je suis retourné dans le Bios, et je n'ai rien vu de changé, mais je ne suis pas trop calé dans ce domaine (non plus !). HP a mis en ligne une émulation du même bios en ligne sur cette page Beaucoup de menu à explorer, et pas vraiment explicite "TPM Embedded Security " "Dynamic Platform and Thermal Framework (DPTF)"...

Ne sachant pas lire et interpréter les log de Xorg et les autres, que reste-il comme solution radicale ? ré-initialiser le Bios, effacer tout le disque et repartir à zéro ? :confus:

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#14Messageil y a 3 mois

c'est bien ce que je pensais
les écran bios deviennent de plus en plus complexe et subordonné à Microsoft

normalement ,
- le TPM est a désactiver
- PXE idem
- Pas de Legacy , pas de SecureBoot ( attention mot de passe admin pour modifier ce point )
- possible que tu garde USB mass storage pour la clé de démarrage
- systems options doivent être toute cochés
-option rom ALL UEFI ( sauf video , Intel a des soucis de sécurité ? )

- sur la partie Wake on , attention suivant usage et consommation

avis perso sur la fonction upgrade intégré par le Bios HP ,
je ne suis pas très fan , car il peut requérir certaines options comme SecureBoot et/ou Legacy ,
et dans ce cas tu devrais voir un certificat par HP à minima

point précis sur la partie USB & démarrage - sécurité ,
Depuis la génération Skylake , Intel a modifié la gestion de mise a jour des cartes mères ,
avant cela pouvait passer par un port interne sérial spécifique , il n'existe plus
donc cela passe par USB.

par contre si à chaque maj et installation des différents noyaux linux tu as un souci au démarrage de noyau
4.14 ou 4.16 voir 4.17 ( il peut être très utile pour du matériel très récent ) , alors il y a un autre souci , sans doute lié a l'extinction

évite les mises en veille et éteins toujours le portable

il y a ce sujet sur manjaro
https://forum.manjaro.org/t/blank-scree ... -450/47710

reste avec un noyau 4.17 si possible avec
linux417-acpi_call
linux417-bbswitch
linux417-r8168
iwlwifi

attention a chaque version majeur linux
tu as des drivers Realtek , iwlwifi , bluetooth

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#15Messageil y a 3 mois

Salut Stéphane et merci d'avoir pris le temps de m'aider :merci:
Maintenant que je n'arrive plus à lancer Manjaro sauf en TTY, la situation est un peu compliqué...
Ubuntu boot toujours bien, même après les changement effectués dans le Bios aujourd'hui sur tes conseils!
C'était déjà bon en grande partie, mais j'ai dû désactiver complètement TPM pour voir...

Autre chose, pourquoi installer bbswitch alors que j'ai désactivé la carte Nvidia, tu es certain de cela ? ou c'est juste pour tout le monde afin d'avoir une config OK ?

Edit : j'ai reformaté mon SSD, et c'est parti pour l'install !
A suivre
(Je me log sans problème, la chance !!! :fete: )
Modifié en dernier par lopasilver le 24 Jui 2018, 15:06, modifié 1 fois.

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#16Messageil y a 3 mois

a priori , je pense que 50% des problèmes viennent de la configuration Bios
pour cette série de portable

si la clé USB manjaro n'est plus vu suite aux modifications , il y a donc un souci ,
et c'est ce que je redoute de la part des fabricants qui ferment les accès ports USB dans ce cas.

de base , c'est les drivers intel pour la vidéo.

je ne sais pas si tu peux faire des copie écrans du bios ( F12 ou impression écran )
sur une clé USB Fat

pour l'instant cela ne passe pas côté manjaro , a voir si tu rencontre les mêmes soucis avec
la version beta Xfce 18 ( nota elle pointe sur le Test , on verra bien si cela pose problème )
https://osdn.net/projects/manjaro/stora ... .0-beta-3/

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#17Messageil y a 3 mois

Désolé, j'ai pris les nerfs (un peu) et j'ai tout formaté.
Install OK et MàJ en cours...
Je me répète :fete::fete::fete:
stephane a écrit :
il y a 3 mois
.../... a voir si tu rencontre les mêmes soucis avec
la version beta Xfce 18 ( nota elle pointe sur le Test , on verra bien si cela pose problème )
https://osdn.net/projects/manjaro/stora ... .0-beta-3/
Téléchargement en cours de cet iso, j'ai de la place : j'ai viré Ubuntu :lol:

Edit : La fête n'aura pas duré longtemps :shock: écran noir et ventilo à donf après les mises à jour et reboot (rien d'autre). J'hésite à ouvrir un nouveau sujet, je vais voir ce que je peux faire moi-même :roll:

Edit2: suis dans la m.. voir 114078

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#18Messageil y a 3 mois

Bonjour,
C'est quel modèle de pc ?
Ça serait pas le méchant bug du kernel d'Ubuntu 17.10 qui t'aurait corrompu le bios ?
Apparemment il a fait beaucoup de dégâts et il n'y a pas de solution lorsqu'Ubuntu est désinstallé.
https://bugs.launchpad.net/ubuntu/+sour ... ug/1734147

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#19Messageil y a 3 mois

je ne le pense pas ,
il peut de son côté faire les maj Firwmare du portable.

s'il a fait les maj de ubuntu 17.10 , il ne devrait pas avoir ce souci , cela a été corrigé
fin décembre 2017

os-prober ne voit pas Manjaro ! [ou boot de Manjaro difficile !]

#20Messageil y a 3 mois

J'ai un HP probook 450 G5, acheté neuf en mars de cette année
Non, j'ai installé Ubuntu 17.10.1 qui est exempt de ce bug

Répondre