Questions générales sur Manjaro Linux.
S'il vous plaît, avant de poster, essayez la fonction de recherche du forum.
Répondre

Nouveau PC, nouvelle distro et plein de questions

#1Messageil y a 1 semaine

Salut à tous,
comme je l'ai dis dans ma présentation, je m'essaye depuis peu à Manjaro.


Je me suis offert récemment un nouveau laptop : un Dell G3 avec Ubuntu pré-installé (pas de licence MS, c'est toujours ça d'économisé ^^).

J'ai laissé le premier disque tel quel (il contient Ubuntu avec les repos Dell, ainsi qu'une partition recovery).
J'y ai installé Steam et les drivers Nvidia, je l'utiliserai de temps en temps (rarement en fait) pour jouer.

Sur le second disque (SSD sata) que j'ai installé moi-même, j'y ai donc installé Manjaro XFCE pour mon usage perso/pro le plus fréquent.

Plus d'infos sur la machine :

$ inxi -Fxxxz
System:    Host: g3 Kernel: 4.20.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN 
           tk: Gtk 3.24.3 info: xfce4-panel wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: G3 3579 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 05K0D2 v: A00 serial: <filter> UEFI: Dell v: 1.5.1 date: 11/01/2018 
Battery:   ID-1: BAT0 charge: 44.9 Wh condition: 56.0/56.0 Wh (100%) volts: 16.0/15.2 model: Samsung SDI DELL W7NKD8C 
           type: Li-ion serial: <filter> status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36872 
           Speed: 900 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: N/A bus ID: 01:00.0 chip ID: 10de:1c8d 
           Display: x11 server: X.Org 1.20.3 driver: intel tty: N/A 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 18.3.2 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Sound Server: ALSA v: k4.20.7-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           chip ID: 8086:a370 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8168 v: 8.045.08-NAPI 
           port: 3000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 704.24 GiB used: 12.68 GiB (1.8%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG30ZMS256G NVMe 256GB size: 238.47 GiB speed: 15.8 Gb/s lanes: 2 
           serial: <filter> rev: ADDA0103 scheme: GPT 
           ID-2: /dev/sda vendor: Samsung model: SSD 750 EVO 500GB size: 465.76 GiB speed: 6.0 Gb/s serial: <filter> rev: 1B6Q 
           scheme: GPT 
Partition: ID-1: / size: 97.93 GiB used: 10.41 GiB (10.6%) fs: ext4 dev: /dev/sda2 
           ID-2: /home size: 342.55 GiB used: 2.27 GiB (0.7%) fs: ext4 dev: /dev/sda3 
           ID-3: swap-1 size: 16.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 259 Uptime: 1h 52m Memory: 7.65 GiB used: 1.47 GiB (19.2%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
           Shell: bash v: 5.0.0 running in: xfce4-terminal inxi: 3.0.30 

Comme je l'ai dis plus tôt, nouvelle machine et nouvelle distro m'amène à me poser plusieurs questions :

1. C'est mon premier dual-boot Linux/Linux, aussi j'ai l'impression que mes deux install Grub entrent en conflit.
J'ai renseigné l'option `GRUB_DISABLE_OS_PROBER=true` dans chaque fichier de config Grub mais l'entrée nommée `ubuntu` de mon menu boot (touche F12) me renvoi vers l'utilitaire de test de Dell.
Ce n'est pas très grave en soit car il m'est toujours possible de sélectionner le disque à démarrer.

2. Le premier disque se déclare NVMe, or il contient les deux "encoches" B+M.
Est-ce bien un NVMe avec un débit théorique de 3-4000 Mo/s ou plutot un SATA au débit approximatif de 600 Mo/s ?
De plus, je serai surpris que ce soit effectivement un NVMe au prix où j'ai acheté la machine.

3. La carte NVIDIA ...
Bien que j'ai sélectionné les pilotes 'nonfree' lors du démarrage de la clef d'install, il semblerait que les drivers proprio ne soient pas installés. En effet, je remarque que "video-linux" est installé.

En fait, je n'ai vraiment besoin de la dGPU si ce n'est que le port HDMI ne fonctionne qu'avec les drivers NVIDIA (port branché sur la carte Nvidia ?). Peut-être que 'intel-virtual-output' pourrait convenir ?


Voilà, j'ai conscience que j'en demande beaucoup et que certaines réponses se trouvent déja dans les forums/wikis mais je préfère avoir vos conseils et remarques avant de faire n'imp' :)

Nouveau PC, nouvelle distro et plein de questions

#2Messageil y a 1 semaine

Comme demandé par @stephane dans mon topic de présentation, voici les non-logs de nvidia :

$ sudo journalctl -b0 -p 4
-- Logs begin at Tue 2019-02-05 13:21:34 CET, end at Sun 2019-02-10 18:37:05 CET. --
févr. 10 17:39:06 g3 kernel: ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
févr. 10 17:39:06 g3 kernel: ENERGY_PERF_BIAS: View and update with x86_energy_perf_policy(8)
févr. 10 17:39:06 g3 kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.SPI1.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20181003/psparse-516)
févr. 10 17:39:06 g3 kernel: ACPI Error: Method execution failed \_SB.PCI0.SPI1.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20181003/uteval-69)
févr. 10 17:39:06 g3 kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.SPI2.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20181003/psparse-516)
févr. 10 17:39:06 g3 kernel: ACPI Error: Method execution failed \_SB.PCI0.SPI2.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20181003/uteval-69)
févr. 10 17:39:06 g3 kernel: i8042: Warning: Keylock active
févr. 10 17:39:06 g3 kernel: ata1.00: supports DRM functions and may not be fully accessible
févr. 10 17:39:06 g3 kernel: ata1.00: supports DRM functions and may not be fully accessible
févr. 10 17:39:07 g3 kernel: acpi PNP0C14:04: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:03)
févr. 10 17:39:07 g3 kernel: wmi_bus wmi_bus-PNP0C14:05: WQBC data block query control method not found
févr. 10 17:39:07 g3 kernel: acpi PNP0C14:05: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:03)
févr. 10 17:39:07 g3 kernel: acpi PNP0C14:06: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:03)
févr. 10 17:39:07 g3 kernel: r8168: loading out-of-tree module taints kernel.
févr. 10 17:39:07 g3 kernel: r8168  Copyright (C) 2017  Realtek NIC software team <nicfae@realtek.com> 
                               This program comes with ABSOLUTELY NO WARRANTY; for details, please see <http://www.gnu.org/licenses/>. 
                               This is free software, and you are welcome to redistribute it under certain conditions; see <http://www.gnu.org/licenses/>. 
févr. 10 17:39:07 g3 kernel: acpi PNP0C14:07: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:03)
févr. 10 17:39:07 g3 systemd-udevd[357]: Process '/usr/bin/set-wireless-regdom' failed with exit code 1.
févr. 10 17:39:07 g3 kernel: uvcvideo 1-5:1.0: Entity type for entity Extension 4 was not initialized!
févr. 10 17:39:07 g3 kernel: uvcvideo 1-5:1.0: Entity type for entity Extension 7 was not initialized!
févr. 10 17:39:07 g3 kernel: uvcvideo 1-5:1.0: Entity type for entity Processing 2 was not initialized!
févr. 10 17:39:07 g3 kernel: uvcvideo 1-5:1.0: Entity type for entity Camera 1 was not initialized!
lines 1-24...skipping...
-- Logs begin at Tue 2019-02-05 13:21:34 CET, end at Sun 2019-02-10 18:37:05 CET. --
févr. 10 17:39:06 g3 kernel: ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
févr. 10 17:39:06 g3 kernel: ENERGY_PERF_BIAS: View and update with x86_energy_perf_policy(8)
févr. 10 17:39:06 g3 kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.SPI1.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20181003/psparse-516)
févr. 10 17:39:06 g3 kernel: ACPI Error: Method execution failed \_SB.PCI0.SPI1.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20181003/uteval-69)
févr. 10 17:39:06 g3 kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.SPI2.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20181003/psparse-516)
févr. 10 17:39:06 g3 kernel: ACPI Error: Method execution failed \_SB.PCI0.SPI2.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20181003/uteval-69)
févr. 10 17:39:06 g3 kernel: i8042: Warning: Keylock active
févr. 10 17:39:06 g3 kernel: ata1.00: supports DRM functions and may not be fully accessible
févr. 10 17:39:06 g3 kernel: ata1.00: supports DRM functions and may not be fully accessible
févr. 10 17:39:07 g3 kernel: acpi PNP0C14:04: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:03)
févr. 10 17:39:07 g3 kernel: wmi_bus wmi_bus-PNP0C14:05: WQBC data block query control method not found
févr. 10 17:39:07 g3 kernel: acpi PNP0C14:05: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:03)
févr. 10 17:39:07 g3 kernel: acpi PNP0C14:06: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:03)
févr. 10 17:39:07 g3 kernel: r8168: loading out-of-tree module taints kernel.
févr. 10 17:39:07 g3 kernel: r8168  Copyright (C) 2017  Realtek NIC software team <nicfae@realtek.com> 
                               This program comes with ABSOLUTELY NO WARRANTY; for details, please see <http://www.gnu.org/licenses/>. 
                               This is free software, and you are welcome to redistribute it under certain conditions; see <http://www.gnu.org/licenses/>. 
févr. 10 17:39:07 g3 kernel: acpi PNP0C14:07: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:03)
févr. 10 17:39:07 g3 systemd-udevd[357]: Process '/usr/bin/set-wireless-regdom' failed with exit code 1.
févr. 10 17:39:07 g3 kernel: uvcvideo 1-5:1.0: Entity type for entity Extension 4 was not initialized!
févr. 10 17:39:07 g3 kernel: uvcvideo 1-5:1.0: Entity type for entity Extension 7 was not initialized!
févr. 10 17:39:07 g3 kernel: uvcvideo 1-5:1.0: Entity type for entity Processing 2 was not initialized!
févr. 10 17:39:07 g3 kernel: uvcvideo 1-5:1.0: Entity type for entity Camera 1 was not initialized!
févr. 10 17:39:07 g3 kernel: thermal thermal_zone8: failed to read out thermal zone (-61)
févr. 10 17:39:07 g3 kernel: iTCO_wdt iTCO_wdt: can't request region for resource [mem 0x00c5fffc-0x00c5ffff]
févr. 10 17:39:07 g3 kernel: iTCO_wdt: probe of iTCO_wdt failed with error -16
févr. 10 17:39:07 g3 systemd-udevd[362]: Process '/usr/bin/tlp auto' failed with exit code 4.
févr. 10 17:39:07 g3 kernel: ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20181003/nsarguments-66)
févr. 10 17:39:07 g3 kernel: i2c_hid i2c-DELL086F:00: i2c-DELL086F:00 supply vdd not found, using dummy regulator
févr. 10 17:39:07 g3 kernel: i2c_hid i2c-DELL086F:00: i2c-DELL086F:00 supply vddl not found, using dummy regulator
févr. 10 17:39:08 g3 kernel: psmouse serio1: synaptics: device claims to have extended capabilities, but I'm not able to read them.
févr. 10 17:39:08 g3 kernel: psmouse serio1: synaptics: device claims to have extended capability 0x0c, but I'm not able to read it.
févr. 10 17:39:08 g3 systemd-udevd[356]: Process '/usr/bin/alsactl restore 0' failed with exit code 99.
févr. 10 17:39:08 g3 kernel: iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS
févr. 10 17:39:08 g3 kernel: iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS
févr. 10 17:39:08 g3 kernel: psmouse serio1: synaptics: Unable to initialize device.
févr. 10 17:39:10 g3 kernel: kauditd_printk_skb: 23 callbacks suppressed
févr. 10 17:39:14 g3 kernel: psmouse serio1: Failed to enable mouse on isa0060/serio1
févr. 10 17:39:17 g3 kernel: iwlwifi 0000:00:14.3: Unhandled alg: 0x707
févr. 10 17:39:17 g3 kernel: iwlwifi 0000:00:14.3: Unhandled alg: 0x707
févr. 10 17:39:17 g3 kernel: iwlwifi 0000:00:14.3: Unhandled alg: 0x707
févr. 10 17:39:18 g3 org.blueman.Mechanism[573]: Unable to init server: Could not connect: Connection refused
févr. 10 17:39:18 g3 org.blueman.Mechanism[573]: Unable to init server: Could not connect: Connection refused
févr. 10 17:39:18 g3 python[1095]: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
févr. 10 17:39:18 g3 kernel: iwlwifi 0000:00:14.3: Unhandled alg: 0x707
févr. 10 17:39:20 g3 kernel: iwlwifi 0000:00:14.3: Unhandled alg: 0x707
févr. 10 17:39:25 g3 ModemManager[578]: <warn>  Could not grab port (tty/ttyACM0): 'Cannot add port 'tty/ttyACM0', unhandled serial type'
févr. 10 17:39:25 g3 ModemManager[578]: <warn>  Couldn't create modem for device '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-9': Failed to find primary AT port
févr. 10 17:39:29 g3 gnome-keyring-daemon[855]: couldn't read file in user store: Riseup_Networks.cer: L’ouverture du fichier « /home/sebastien/.local/share/keyrings/Riseup_Networks.cer » a échoué : Aucun fichier ou dossier de ce type
févr. 10 17:39:30 g3 kernel: kauditd_printk_skb: 5 callbacks suppressed
févr. 10 17:39:31 g3 gnome-keyring-daemon[855]: asked to register item /org/freedesktop/secrets/collection/login/797, but it's already registered
févr. 10 17:39:32 g3 gnome-keyring-daemon[855]: asked to register item /org/freedesktop/secrets/collection/login/797, but it's already registered
févr. 10 17:40:38 g3 systemd[1]: tinyproxy.service: Start operation timed out. Terminating.
févr. 10 17:40:38 g3 systemd[1]: tinyproxy.service: Failed with result 'timeout'.
févr. 10 17:40:38 g3 systemd[1]: Failed to start Tinyproxy Web Proxy Server.
févr. 10 17:42:13 g3 systemd[1]: tinyproxy.service: Start operation timed out. Terminating.
févr. 10 17:42:13 g3 systemd[1]: tinyproxy.service: Failed with result 'timeout'.
févr. 10 17:42:13 g3 systemd[1]: Failed to start Tinyproxy Web Proxy Server.
févr. 10 17:43:49 g3 systemd[1]: tinyproxy.service: Start operation timed out. Terminating.
févr. 10 17:43:49 g3 systemd[1]: tinyproxy.service: Failed with result 'timeout'.
févr. 10 17:43:49 g3 systemd[1]: Failed to start Tinyproxy Web Proxy Server.

$ sudo journalctl -b0 | grep nvidia
$

Nouveau PC, nouvelle distro et plein de questions

#3Messageil y a 1 semaine

peux tu ajouter stp

sudo fdisk -l

Nouveau PC, nouvelle distro et plein de questions

#4Messageil y a 1 semaine

$ sudo fdisk -l
Disque /dev/nvme0n1 : 238,5 GiB, 256060514304 octets, 500118192 secteurs
Modèle de disque : KBG30ZMS256G NVMe TOSHIBA 256GB         
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : gpt
Identifiant de disque : AC65E18F-14E6-4C47-9498-FE72FE873EE7

Périphérique       Début       Fin  Secteurs Taille Type
/dev/nvme0n1p1      2048   1538047   1536000   750M Système EFI
/dev/nvme0n1p2   1538048  12023807  10485760     5G Réservé Microsoft
/dev/nvme0n1p3  12023808 467136511 455112704   217G Système de fichiers Linux
/dev/nvme0n1p4 467136512 500117503  32980992  15,7G Partition d'échange Linux


Disque /dev/sda : 465,8 GiB, 500107862016 octets, 976773168 secteurs
Modèle de disque : Samsung SSD 750 
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : gpt
Identifiant de disque : 2CB6EF55-F28C-48F3-8147-D8FB083236DF

Périphérique     Début       Fin  Secteurs Taille Type
/dev/sda1           34   1535999   1535966   750M Système EFI
/dev/sda2      1536000 211251199 209715200   100G Système de fichiers Linux
/dev/sda3    211251200 943218687 731967488   349G Système de fichiers Linux
/dev/sda4    943218688 976773134  33554447    16G Partition d'échange Linux
Tu constateras que chaque disque possède sa partition EFI, toutes les deux montées en /boot/efi dans leur OS respectifs. (c'est la que ca dois chier dans la colle) :?

De même, chaque disque possède une partition swap, ca peut paraitre idiot mais :
1. je suis pas à 16Go près (oui je sais, en plus y a que 8Go de ram ...)
2. ainsi, chaque disque est totalement indépendant de l'autre (possibilité d'en enlever un sans que ca pose problème sur l'install de l'autre disque).

Nouveau PC, nouvelle distro et plein de questions

#5Messageil y a 1 semaine

alors efi --> gpt , /boot/efi en fat32
verifie avec gparted qui a option boot & esp
c'est un des 2 disques ( pas les 2 )

Nouveau PC, nouvelle distro et plein de questions

#6Messageil y a 1 semaine

stephane a écrit :
il y a 1 semaine
alors efi --> gpt , /boot/efi en fat32
verifie avec gparted qui a option boot & esp
c'est un des 2 disques ( pas les 2 )
J'ai les flags sur les deux partitions EFI. J'ai manuellement ajouté les flags sur la partition du second disque quand je l'ai partitionné.

http://xn--pp-oia.com/Hird - gparted-nvme0n1.png
http://xn--pp-oia.com/Hire - gparted-sda.png

Nouveau PC, nouvelle distro et plein de questions

#7Messageil y a 1 semaine

Perso, je ne laisserais que le flag /boot/esp sur /dev/sda2. Deux partitions Efi cohabitent mal. Bien sur, il faudra indiquer ce disque en tête de liste dans les préférences du menu du Bios (Uefi).
Ensuite, je passerais la main à Manjaro sur Grub pour des raisons liés aux kernels (microcode) . Voir ici:
95169

Nouveau PC, nouvelle distro et plein de questions

#8Messageil y a 1 semaine

Salut @lemust83,
tu m'indique de mettre les flags sur la partition /dev/sda2 (point de montage "/"), tu voulais pas plutot parler de la partition /dev/sda1 (point de montage "/boot/efi") ?

Concernant le microcode Intel, il semblerait que je n'en ai pas besoin. La commande suivante ne m'a rien affiché :

[[ $(dmesg | grep "microcode updated" -c) > 0 ]] && echo "j'ai besoin du intel microcode"
Actuellement, le fait que les deux disques soient indépendant l'un de l'autre fonctionne plutot bien.
Chaque disque/OS contient son Grub. Lors des mises à jours, chaque OS peut mettre à jour son Grub et lister ses anciennes versions le cas échéant. Les deux Grub sont configurés pour ignorer l'autre disque/OS.

Le problème se situe surtout au niveau du menu boot Dell (touche F12) où une entrée est mal configurée. J'ai vu qu'il y avait moyen d'éditer ces infos dans/depuis le BIOS, il faudrait que j'essaye...
Je vais essayer de prendre quelques photos, ce sera plus facile à expliquer ;)


edit: J'ai modifié le menu boot depuis le BIOS et ça semble faire le taf. Je verrai à l'usage si ça tourne bien sur le long terme..

Répondre