Questions générales sur Manjaro Linux.
S'il vous plaît, avant de poster, essayez la fonction de recherche du forum.

faut être précis ! soucis distib !

#21Messageil y a 3 mois

bonjour

le retour est incomplet pour sda ,
il faut mettre balise [ code ] et [ / code ] ( sans les blanc ) pour le texte formatté

a titre exemple démarrage efi avec /boot/efi , le disque doit être GPT ( et non DOS = MBR )
( /boot est dans ce cas dans / en ext4 , les images de démarrages noyaux y sont sans problème de taille de partition )

sudo disk -l

Disque /dev/sda : 465,8 GiB, 500107862016 octets, 976773168 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : gpt
Identifiant de disque : AD5C25D0-F35C-4923-B016-88C4C5820FA5

Périphérique    Début       Fin  Secteurs Taille Type
/dev/sda1        2048    411647    409600   200M Système EFI
/dev/sda2      411648  51611647  51200000  24,4G Système de fichiers Linux
/dev/sda3    51611648 976773119 925161472 441,2G Système de fichiers Linux

sudo lsblk -fs

NAME  FSTYPE     LABEL       UUID                                 MOUNTPOINT
sda1  vfat                   E05B-8683                            /boot/efi
└─sda                                                             
sda2  ext4       root        aa940861-9549-4d9c-8a95-6e556d073aa5 /
└─sda                                                             
sda3  ext4       home        05923b1e-dbe7-4d73-9440-2c067e027f1a /home


faut être précis ! soucis distib !

#22Messageil y a 3 mois

@stéphane:

sudo fdisk -l
Disque /dev/sda1:698,7GiB,750156374016ostets,1465149168secteurs
Unités: secteur de 1x512:512Octets
Taille de secteur(logique/physique):512oct/4096oct
Taille d'E/S(Minimale/Optimale):4096oct/4096oct
Type d'étiquette de disque: gpt
ID Disque:OE877777-F185-.......
périphérique   Début     Fin       Secteurs      Taille      Type
/dev/sda1       4097    618497    614401       300M      Système EFI
/dev/sda2     618498  1447875788   1447257291  690,1G  Systèm de fich Linux
/dev/sda3  1447875789  1465144064  17268276  8,2G  Partition d'échange Linux
Modifié en dernier par Erwan le 09 Mar 2018, 18:04, modifié 1 fois.

faut être précis ! soucis distib !

#23Messageil y a 3 mois

@stéphane
Il faut se rappeler que nos échanges se font sous vista w$, je ne peux pas passer sous Linux
avant fin semaine prochaine.
Je suis OBLIGE de passer par là tant que manjaro n'est pas fonctionnel!
Donc toutes mes gravures d'iso passent par la moulinette W$....
Pour calamarès, c une archive tar.gz que je ne peux pas rentrer ds la machine en rade!
Est-ce que mon mess d'avant te dit qqchose ?
Je n'arrive pas à booter sur usb, c'est une option qui n'apparait même pas dans le BOOT OPTION
Donc je n'arrive pas en live session !
Je reviens tj a cette ligne de commande verte !
(c'est déjà ça !)
Je suis bien sûr pret a tout réinstaller, mais est-ce encore possible ?
Bien
@stéphane
bien sûr la patience est mère d’apprentissage, mais je regarde sur plein de sites,
je suis bien loin d'être un geek, suis pas trop newbie ( goupil & TO 7, ça dégoute,
parfois), mais là, un system tip top, open surtout, mais qu'est-ce qui c'est passé.
La commande par console ne me rebute pas.
Vous êtes très réactifs, mais, si ce schmilibilibilic pouvait avancer , ah , là
je vends toutes mes parts de chez M$, tient, je les donnes.... :mrgreen:

faut être précis ! soucis distib !

#24Messageil y a 3 mois

bonsoir

je vais faire un petit résumé pour que tu comprenne la situation :
tu as 2 disques ,
sda et sdb
sdb , il y a windows7 en Dos ( MBR) avec amorcage , microsoft a eu comme idée de mettre /boot/efi sur du MBR , linux ne le gère pas , seul le bios peut le lancer ( sans EFI )

sda tu as installé manjaro en efi , avec /boot/efi , sauf que :
si le Bios au démarrage ne connait pas le chemin de cet efi
( sous le bios on a alors un nom du genre EFI: <disque ou nom distribution Linux> )
alors ce dernier démarre en legacy , et sur sdb car il a une info ou ce trouve l'amorçage

en gros , tu as quelques chose d'hybride , du coup , la clé USB ne démarre pas ou n'est plus visible , et il ne te reste que ce terminal , or la manjaro ici ne parviens pas à démarrer correctement

1 - quand tu démarre sur sda , tu as le menu texte grub qui apparaît ou pas ?
2 - si oui , alors on a bien un moyen de démarrer et tu as un souci sur les services à démarrer
3 - windows lui prends la main sinon

lors de l'installation manjaro ( CD ou DVD iso ou cle USB) tu as du voir 2 types de partitions
dev/sdx ( cad ici MBR - Bios )
dev/sdx1 ( ici EFI )

en choisissant l'un ou l'autre , l'installation va se faire en mode bios ou EFI ,
à condition , que de ton côté ton choix sur le disque et le mode de démarrage soit identique ,
tu ne peux pas démarrer sur MBR (disque DOS) de l'EFI sous linux
tu peux démarrer sur GPT en Bios ou en EFI.

dans immédiat reste sur windows et ne touche pas à la config du Bios.

4 - sur le sda (linux) as tu besoin de sauvegarder des données , notamment du répertoire /home ?

merci de répondre sur ces 4 points

faut être précis ! soucis distib !

#25Messageil y a 3 mois

@stéphane
Bonjour& merci pour ta patience et tes topos!
J'imagine la difficulté de la "mission", surtout à distance, presque en aveugle...
Bon
Manjaro c'est installé tout seul avec une clef que j'avais créée depuis Ubuntu 16:04.
L'install c'est faite toute seule, en auto, et j'ai collé toutes mes archives perso dans les différent dossiers, grace a un DD ext usb, que j'ai toujours, et qui est clean !
Il peut tout à fait refaire ce qu'il a fait, ça prends du temps, mais bon .
Donc, tu as bien compris que, pour l'instant, ma seule connection se fait grace à
un vieil ordi sous vista, très très lent !
L'autre en rade, au jour d'aujourd'hui, quand je l'allume, m'indique les érreurs et que sda2 est clean, suit une check list ou c ok jusqu'a networkmanager.. Là, nouvelle fenêtre;
Manjaro Linux
4.14.21-1-Manjaro (ordi-fred)(tty1)
ordi-fred login;...(je met ordi-fred)
Password: je met mon psw root
[ordi-fred@ordi-fred~]$:

sdb, c'est pour l'instant juste une clé usb avec gravure iso Manjaro

Et, j'ai toujours le DD ext usb de 1T ou sont toutes mes datas perso.

A priori, je peux tout a fait réinstaller manjaro et me fâder les transferts.

Bien
ordi-fred

faut être précis ! soucis distib !

#26Messageil y a 3 mois

MdR, LOL, j'ai encore du mal avec les balises...dsl
@stéphane
pour être tout a fait clair(?):
OUI GNU-GRUB 2.03 s'affiche au démarrage sur le sda, avec Manjaro ou manjaro spécifique.
OUI j'ai toutes mes archives sur DD ext usb.
Bien
ordi-fred

faut être précis ! soucis distib !

#27Messageil y a 3 mois

ok donc

démarche pour la suite
-sous le bios , sauvegader la config windows
-ensuite faire un reset bios , pour retrouver la configuration de boot avec la clé USB install

si tu as copié avec Rufus pour faire iso sur la clé USB , le faire en mode DD uniquement ou autre ( etcher )

objectif : retrouver un démarrage sur la clé USB

si problème tu as la config windows pour redemarrer

faut être précis ! soucis distib !

#28Messageil y a 3 mois

@stéphane
Bonjour
Pour re-graver iso manjaro je suis passé par tout les outils !
etcher ne fonctionne qu'avecW$7 et+, Rufus ok mais ancienne version, iso to usb,...
Et UNetbootin pour avoir manjaro sur ma clé sdb version xfce-17.1.04, mais à chaque
fois ma gravure est tatouée W$...
J'imagine que tu souhaites que je clone le grub grâce au boot de la clé (?), mais j'arrive
pas a faire démarrer l"Asus ou manjaro est(ait) installé par le biais de cette clé !
Elle est reconnue seulement quand le "boot" est fait sur sda...
A chaque fois je reformate complètement ma clé 16GiB mais rien n'y fait, probablement
parce-que je télécharge et l'iso et l'outil de gravure sous windows vista....
Bon, sous peu, il fera jour !
Bonne journée

faut être précis ! soucis distib !

#29Messageil y a 3 mois

@stéphane
Et si je virais tout simplement w$ vista complètement du vieil ordi, chose que je
voulait faire de toute façon...
La, j'aurais peut-être moyen de bosser avec du Linux d'un bout à l'autre ???

faut être précis ! soucis distib !

#30Messageil y a 3 mois

@ tous, bonjour, je vais démerder cette histoire tout seul, et comme j’aurais surement besoin , un jour, de vos avis éclairés, je vous remercie pour toutes ces infos.
Cette question est donc close ( presque....).
ordi-fred

faut être précis ! soucis distib !

#31Messageil y a 3 mois

Bonjour
Si tu as W$ 7 , c'est que tu boot via le MBR donc la présence ou non de W$ ne devrait pas poser de problème.
Cela dit, il y a longtemps que je suis sevré de ce truc. :gsourire:

faut être précis ! soucis distib !

#32Messageil y a 3 mois

@lemust83
Ahahah pour W$...d'ailleurs c'est même pas du 7, c'est juste avant !!!
Le piège quoi, m'enfin, c'est le seul que j'ai sous la main, et son sort
sera réglé dés Samedi !
Je vire cette saloperXXXXXXX d'OS et met du light et xfce vu l'age
canonique de l'engin.
Bon, ya pire, 2g de Ram et 170g en DD...
Ça devrai le faire.
En tout cas, merci pour tout.
Vous tiendrais au jus, because Manjaro+Gnome ben c'est juste très bien !
Bien et belle journée.
Fred
Ps: ai répondu au mp de stéphane

Répondre