Le coin des remarques, suggestions et bugs à faire remonter.
Répondre

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#1Messageil y a 1 an

Salut à tous,
Pour celles et ceux qui utilisent le lecteur de pdf qpdfview attention, lors des prochaines mises à jour, testing puis stable, un update de poppler-qt5 brise le lecteur compilé le 1er mai 2016 par oberon. Prévoir donc un second lecteur de secours au cas où un patch ne serait pas fournit d'ici là :clindoeil:

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#2Messageil y a 1 an

aucun probleme sous arch stable avec la version de ce jour ...

qpdfview 0.4.17beta1-2
poppler-qt5 0.55.0-3 (05 juin 2017)

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#3Messageil y a 1 an

Merci du retour papajoke, tu es sur une Arch testing ? Concernant Manjaro (instable) c'est ce paquet qui vient de rentrer aujourd'hui : poppler-0.55.0-2-x86_64.pkg.tar.xz et concernant qpdfview, aucune mise à jour depuis un an (communauté) :

qpdfview
Version                  : 0.4.16-4

qpdfview 0.4.17beta1-2:shock:

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#4Messageil y a 1 an

comme dit + haut suis en stable :clindoeil:
0.55.0-3 entrée aujourd'hui et pas de problème

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#5Messageil y a 1 an

Bonjour
Je confirme que qpdfview en 0.4.16-4 est aux fraises... Je suis en testing.
Je regarderai sur la Tour et sur Arch voir si c'est pareil.

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#6Messageil y a 1 an

:bjr: ça n'aura duré que quelques heures, mise à jour de poppler (version Arch), ce matin même. qpdfview reste quant-à lui sur la version stable de l'an dernier, le paquet "dev" installé chez papajoke provenant de Aur :clap

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#7Messageil y a 1 an

arrivée de poppler-0.55.0-3 dans les dépôts stable :gsourire:

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#8Messageil y a 1 an

'LLo,

Tant que l'on y est (en unstable),il y a une maj de manjaro-system qui devient manjaro-system-ng ce mâtin qui impose d''aller bricoler pacman.conf pour passer en graphique (pamac/octopi) car il est verrouillé/tenu par pacman !
Il suffit donc avant de virer manjaro-system de la ligne suivante (18):
HoldPkg = pacman glibc manjaro-system
Comme dans le pacman.conf.pacnew fraichement débarqué juste à côté..! :siffle

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#9Messageil y a 1 an

Maj du jour faite mais c'est poppler-0.55.0-2 chez moi...

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#10Messageil y a 1 an

En stable :
cela doit dépendre des miroirs , le changement pour ce paquet vient juste d'être fait après les premières mises à jour : ce matin c'était la version -2
sur ma cinnamon c'est -2 et sous kde : -3 :siffle

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#11Messageil y a 1 an

Plus qu'à attendre... :manger:

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#12Messageil y a 1 an

:salut:extra/poppler 0.55.0-3 pour Xfce, ce matin :clindoeil: @fassil, oui effectivement nouveau pacnews concernant pacman, pas encore traité au roundup:gsourire:
ps : pas de verrouillage chez moi mais il est vrai que kalu remplace pamac/octopi. :siffle
[Edit] : Je viens d'allumer le laptop histoire de vérifier et suite à cette mise à jour, sans toucher au .pac, pamac est opérationnel. Par ailleurs j'ai ce message en console :

avertissement : fichier de configuration /etc/pacman.conf, ligne 20 : l’instruction « SyncFirst » dans la section « options » n’est pas valide.
C'est donc la ligne 20 qu'il faut ou supprimer ou bien commenter. J'ai simplement commenté provisoirement pour ôter ce vilain message qui déshonore mon terminal car manjaro-sytem-ng doit être mis à jour en premier, non ? J'enlèverai le dièse dés que possible et le remplacerait par un triple bémol :rigole:

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#13Messageil y a 1 an

Maj des paquets faite et c'est de nouveau ok. :clindoeil:

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#14Messageil y a 1 an

:salut: Concernant la mise à jour de pacman c'est bien l'ami fassil qui avait raison sur la méthode.

You had an old pacman.conf. We updated it for you.
==> You can find your old pacman.conf saved as `/etc/pacman-old-06074215.conf`
"SyncFirst" et manjaro-system ou manjaro-system-ng doivent être supprimés du fichier de conf :clindoeil: Cela signifie également que lorsque ces paquets passeront en "stable", il n'y aura rien à faire ni de .pac à traiter, les devs l'ont fait pour nous :clap

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#15Messageil y a 1 an

en fait suis vraiment pas fan :maisnon:

code source

if [ "$(vercmp $2 5.0.2-0.4)" -lt 0 ] && [ -f "/etc/pacman.conf.pacnew" ]; then
        msg "You had an old pacman.conf. We updated it for you."
        msg "You can find your old pacman.conf saved as \`/etc/pacman-old-${PACMAN_OLD}.conf\`"
        mv /etc/pacman.conf /etc/pacman-old-${PACMAN_OLD}.conf
        mv /etc/pacman.conf.pacnew /etc/pacman.conf
fi

il copie simplement tout le .pacnew dans le fichier.conf :choc:

--------------
pour la petite histoire, SyncFirst était une fonctionnalité uniquement manjaro, manjaro modifiait le code source de pacman pour ajouter cette fonctionnalité. Prochainement manjaro utilisera les hook pour exécuter manjaro-system-ng

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#16Messageil y a 1 an

papjoke : Prochainement manjaro utilisera les hook pour exécuter manjaro-system-ng
Je me posai justement la question de savoir comment manjaro-system-ng s'exécuterait :merci:

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#17Messageil y a 1 an

Pour l'instant, en Testing, j'ai toujours SyncFirst d'actif, et pas de pacman.conf.old. J'attends la prochaine MàJ; il y en a eu une hier.

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#18Messageil y a 1 an

papajoke a écrit :en fait suis vraiment pas fan :maisnon:

code source

if [ "$(vercmp $2 5.0.2-0.4)" -lt 0 ] && [ -f "/etc/pacman.conf.pacnew" ]; then
        msg "You had an old pacman.conf. We updated it for you."
        msg "You can find your old pacman.conf saved as \`/etc/pacman-old-${PACMAN_OLD}.conf\`"
        mv /etc/pacman.conf /etc/pacman-old-${PACMAN_OLD}.conf
        mv /etc/pacman.conf.pacnew /etc/pacman.conf
fi

il copie simplement tout le .pacnew dans le fichier.conf :choc:

--------------
pour la petite histoire, SyncFirst était une fonctionnalité uniquement manjaro, manjaro modifiait le code source de pacman pour ajouter cette fonctionnalité. Prochainementmanjaro utilisera les hook pour exécuter manjaro-system-ng


Et bien voilà, c'est fait, manjaro-sytem-ng est tombé dans l'obsolescence (listé en local dans yaourt -Qam) manjaro-system se trouve encore dans "Core" pour la branche stable mais ses jours sont comptés ou je n'ai rien compris ?? :saispas:

[INSTABLE] du 5 juin 2017 qpdfview cassé !

#19Messageil y a 1 an


[INSTABLE] du 5 juin 2017 qpdfview cassé !

#20Messageil y a 1 an

En effet, ça bouge pas mal ces temps-ci, j'imagine que la manœuvre qui consiste à utiliser les "hooks" doit présenter quelques petites difficultés.

Répondre